Cannot Find Element - No Error in Selector Editor

Hi team,

I’m receiving a ‘Cannot find element’ error but strangely after the error occurs during the run process the Selector Editor is still showing ‘Validate’ & it can locate the element via the ‘Highlight’

I have also created a Indicate Anchor via the UI Explorer but I am still receiving the error. It is puzzling because in the past this error is either due to a variable property that I need to replace with ‘*’ or I need to add another property such as aaname & the Validate would not appear after running the bot

Any ideas as to why this element cannot be located?

Thanks for your help!



Apologies the element is the ‘File Name’ box in the Windows Explorer

is that TYPE INTO activity is placed inside a ATTACH WINDOW ACTIVITY
if not place that inside the attach window and try once
because this is a separate window

Cheers @Mturks

Hi @Palaniyappan

I didn’t have the ATTACH WINDOW function originally but now I do but unfortunately still the same error

Below is a shot of my new process

Any ideas what it still cannot locate the element?



we have two options
either we can use TYPE INTO activity and with just the input string.alone, within attach window
ensure that simulate type property is enabled

we can use GET ACTIVE WINDOW activity and use TYPE INTO ACTIVITY and mention the input string without choosing any element

Cheers @Mturks

Hi @Palaniyappan

No luck on either of those 2 unfortunately

The part that has me puzzled is that I have already entered text into this window in a previous step, where I change the Windows Explorer address & there is no issue with this so it seems the problem is primarily with that element in the windows explorer, not the windows explorer itself

Have you ever experienced where the Selector Editor is valid even after the error?



Below is a screenshot of the explorer, the top address in yellow is what I have edited in a previous step & the process flow

1 Like

Aah got it
So directlybwe can mention that file name along with that path
That is
You can remove this attach window itself and keep the remaining
But in type into change the selector to click on the field FILE NAME instead of SEARCH BAR
-there we can mention the Filename along with folderpath and it will get saved in that folder
We don’t need to first type the folder path and then save the file with separate type into activity

So the sequence be like this
—type into (but select the FILE NAME field and mention the folderpath\filename
—send hot key with key as enter

Or here we can use the previous suggested step
That is we can use GET ACTIVE WINDOW activity and use TYPE INTO ACTIVITY and mention the input string without choosing any element

Cheers @Mturks

I am having the exact same issue. Worked fine a week ago, but now the robot cant find the excel filename field when running. It can find it in selector editor and UI explorer.