Selector finding the element but not clicking

Hi everyone,

I am creating an automation that is saving a query to a local folder in my computer. The "Do you want to open or save menu is coming up (pictured below),

I have tried a click activity, a web recorder using click’s, a retry scope activity and in each case, it finds the little down arrow but it does not click so I can save as. If I manually click, the rest of the automation works fine but the robot refuses to click.

Does anyone have any suggestions?

1 Like

Have you tried using an Attach Window for the popup save dialog box? Ran into this issue before and that seemed to work for me.

1 Like

I like this term buddy

Actually it’s not like robot refuses
Just we need few more properties to be enabled so that this can be
Did we enable SIMULATE CLICK property in property
If not kindly enable that and try once


If it’s enabled we got many options to handle it
Even this was discussed in our forum many times
Kindly have a view on this

Pls try this and let know for any queries or clarification

Cheers @hall1570

Try to use click image activity for opening that drop down and the other stuff…

Hi @hall1570

check this screenshot it will help you


Kommi Jeevan.

Hi abhay, the click image activity does work but there are numerous arrows on the screen and it never clicks the right one.


Thank you for looking into my request, your advice is always helpful. I have indicated under properties to “Simulate Click”. Please see the screenshot of my click activity properties below:

click activity properties

It still does not work but if I click the arrow manually, the robot takes over and clicks “Save As” and continues with the automation.

1 Like

I have also clicked that black box again so it displays the checkmark and True in the next box. It still does not work.

The click image activity works if I use a screen clip and get the area I want to be right in the center of the target. Thanks.

Hey, this is how my sequence looks like. The most important part is the selector, and I believe I got that by doing a recording and copying it from there. Hope this helps.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.