Issue with click activity

Hi All,

I am facing a strange issue with click activity. I am trying to click the web element “Upload Resume” and selectors are also valid. I tried multiple times, but every time the pointer goes to the element but it’s not clicking.
I need to manually click in order to complete my process. I can not upload my XAML file for reference.
Has anybody faced a similar issue? How can I resolve this?

Thanks in advance!!

can you paste the selector here


open in UI Explorer and change the selectors properties and try
try using Indicate anchor in Ui explorer too

is SIMULATE CLICK property of CLICK activity enable

@Anamika15 - You can do one thing First use Hover Activity with same selector and then use Click Activity with same selector that will work for sure.

I enabled it, then the pointer was not even going to the desired element. Then I disabled it, now the mouse pointer is going to the element but not clicking.

I tried this, but not working.

is that element lies inside any browser page or a new window
if so make sure that we have used attach browser or attach window activity
use GET ACTIVE WINDOW activity and mention the CLICK activity inside that container so that it will click

Cheers @Anamika15

I tried indicate anchor also in ui explorer, but isssue is still the same, mouse pointer going to the element but not clicking it.

@Anamika15 Did you try with just aaname as the Selector in webctrl ?

yes, aaname is added in selector.

@Anamika15 I meant Just aaname, like <webctrl aaname=‘Upload Resume’ ? :sweat_smile:

The activity is inside open browser only. Do I still need to use Get Active Window? Other buttons are working fine in the same page.
Facing problem with this particular button only.

1 Like

did we try with SEND HOT KEY ACTIVITY with key as tab
that is use N number of send hot key activity with key as tab until it reaches the field we want and once after reaching the field use a final SEND HOT KEY activity with key as enter so that it will click that button
that will work for sure

Cheers @Anamika15

Cursor is not coming to this position using tab. Click is the only option :frowning:

1 Like

did we try with CLICK IMAGE activity

change WaitForReady property to Interactive/Complete and try
and give some delay

yes I tried… same happening with click image.

Tried this as well… but not working…