Click activity doesn't work anymore on process(while process had been working fine until today )

Hi everyone,

I have a process that had been working fine. But today, I’m facing an error like below. when robot tries to click on file (with right click), it isn’t working.

image

When i try to indicate element again, it selects all area in folder.

Also, on iexplorer i could indicate click ‘save as’ button but now i can only indicate all area.
image

What is the reason for this problem, do you have any idea?

Hi @alpersahin

Check this

Thanks
ashwin S

Hi @AshwinS2,

Thank you but i have already built the process exactly with this way (using f2). The point is ui explore or click activity can not recognize some elements when i want to indicate.
Also i dont think so there is a problem in my selector. There are another methods to click what exactly needed. For example; click image activity or using hot keys.

I need to learn the reason of why robot can not indicate some elements on windows or browsers. Is this about updating studio(missing files) or about community edition or anything else?

May be @loginerror could help us?

Hi @alpersahin

The package that covers UiAutomation is this one:
UiPath.UiAutomation.Acitivities

You can give it a try and update it / downgrade it to see if it will help.

Also, if your Studio recently updated, it might be worth checking if the update wasn’t corrupted.
Normally a computer restart helps.

Lastly, just to be sure, please try running Studio as administrator to see if it will help with elements recognition.

1 Like

Hi @loginerror,

Thank you for quick respond. I did all of them step by step. Also deleted studio and installed again. Unfortunately, it is still same :confused:
Finally, i tried this on acme-system downloading a report. But it is again recognize all three buttons combined. When i click on it it returns “The UiElement is no longer valid”.


I remember that one of the topics(that i cant find actually) you mentioned before that "when you try to remove studio you should also clean some files from documents like ‘packages’ ". Is it related with this?

hi @lakshman, @Palaniyappan ,
Could you mind help me for this situtation? I’m stuck. I cant use any click, type into activity as i needed. So far it was always working.

I’ve already use this events on too many projects. What changed?

1 Like

Did send hot key with up as key and followed by that again a send hot key with enter as key, helped us in this
If it’s a chrome browser ensure that the chrome extension is installed and if it’s a IE browser ensure that these steps are followed

Kindly uninstall and reinstall once the chrome extension if it’s already installed
And restart once before retrying

Hope this would help you
Cheers @alpersahin

1 Like

Yes i have already tried that with this way but this time changing file name is not possible without type into. (also set clipboard + ctrl v might be useful but i cant handle it).

I’ve checked where did you say at IE browser but it seems ok.

Finally, the problem is solved. The only thing that i did is changing UI frameworks type from DEFAULT to UI Automation.

image

It is fine but i am not sure the solution about that or it’s just a coincidence :slight_smile:

thank you.

1 Like

Yah that would work either
Because default method Usually works fine with all types of user interfaces.
But it might fail sometime where the UiAutomation is recommended that you use this option with newer apps, when the Default one does not work.
Click here to read more about Active Accessibility and UI Automation.

That’s the reason
Cheers @alpersahin

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.