Screen resolution issue when running process in production environment

robot
settings

#1

Scenario: I am trying to run a process in a production environment (Windows Server 2016). The client does not have orchestrator so there is only an unattended robot installed on the server. When i access the rdp and run the process in studio everything is fine. However when i try to run the process at a certain time, the screen resolution is an issue as some of the ui elements is not visible. I have checked the resolution when the process runs and it gives me 768 x 1024, which is too narrow.

I have tried to edit the UiPath.settings file and here is my current settings:

{
  "NuGetApiKey": "",
  "NuGetServerUrl": "%ProgramData%\\UiPath\\Packages",
  "ActivitiesFeed": "",
  "UiPathServerUrl": "",
  "TracingLevel": "Trace",
  "LowLevelTracing": false,
  "SecureLicenseKey": "",
  "LoginToConsole": false,
  "ResolutionWidth": 1680,
  "ResolutionHeight": 1050,
  "ResolutionDepth": 32,
  "ConnectionString": ""
}

However, the process is still ouputting 768 x 1024 as the screen resolution. I need to adjust the settings so that the process runs with at least 1680x1050. Anyone experienced this before?
Any help much appreciated :slight_smile:

Studio/Version: Studio 2018.1.3

OS Version: Windows Server 2016

Others if Relevant: (workflow, logs, .net version, service pack, etc):


#2

Hello,

You can try using Launch Workflow Interactive activity. This activity has resolution parameter which you need to set at the beginning of the development. You can call your mail workflow in this launch interactive activity easily.

I guess only draw back of this activity is you can not update screen resolution once you run the program, if you need to change resolution, you need to delete activity and create new one.

I am not 100% this will resolve your issue however better to try once.

Regards
Pawan


#3

Hi @nbjerke

What would happen if you set the resolution at the beginning of your process using PowerShell?

Regards
Troy


#4

Hi @pawanbag. I have tried using workflow interactive with no luck.

@tmays Thank you! I will try this and get back to you :slight_smile:


#5

Hi @tmays

I tried your solution with no luck. When executing the powershell command i get an error saying that the video device does not support the resolution. I have tried with several resolutions, including 768x1024…

The rdp session is accessed through citrix so i think that the resolution configuration has to be changed from the server side, and i am looking into it. If anyone else have any experience with this please comment :slight_smile:


#6

Hey @nbjerke. It was worth a try. Once you figure it out, please share your solution for others following in your footsteps. :slight_smile:


#7

I have used Launch Interactive but when I take a screenshot while it’s running, it actually still runs at 800x600 or 1024x768

I was curious to see if the UiPath.settings resolutions would resolve this too.

There appears to be a flaw with UiPath from my perspective.

However, I have been getting Image activities to work using Launch Interactive but just the screen is smaller. So, if it’s just that stuff isn’t on the screen, can you try using PgDn or Scrolling to place items in the screen? @nbjerke

Please share if you are able to get it to show the screen in proper resolution size. On the other hand, I have gotten 100% of my processes to work regardless.

Thanks.


#8

Did you ever fix this issue. I have exactly the same issue, on my production server if I connect via RDP and start the robot it works at the client resolution. If the robot runs itself I can’t get more than 1280x800 causing the application being automated to not display correctly.

I’ve tried all the UiPath setting plus registry changes on the server to try to force a resolution but with no luck. As it stands I have to manually connect and start this robot every morning which obviously isn’t a long term solution.


#9

Did you set the desired resolution for the robot in uipath settings?


#10

Hi,

I have not found a solution to this problem. I had to redesign my workflow to work with a 1024x768 resolution. I have tried the same as @bobpeers, changing the uipath settings and registry with no luck. I do believe that it is an issue with the citrix vm which runs windows server 2016, that has been set up with a standard resolution 1024x768. In a previous project i have managed to change the resolution by adjusting the settings file or the runtime settings in orchestrator, however that server was a local one, that we connected directly via RDP and not citrix. Do you have any experiences with this @Gabriel_Tatu?


#11

Yes, it has no effect at all.


#12

Thanks, unfortunately our application is unusable at 1024 x 768 :frowning: I also think this is connected to limitations on the server side. We use VMWare vCloud and it could be related to the virtual video driver not supporting higher resolutions. We are currently contacting our virtual host provider to see if they can help.

I’ll update here if I find out anything.


#13

To update we have fixed this issue. It was due to a lack of video memory on the virtual server so no matter what I set in UiPath.settings it would never go above 1280x800.
We now had our provider add VRAM (we could no do this ourselves through the vCloud console) and after a reboot the UiPath.settings file works and we can get a 1920 x 1080 resolution.


#14

Thanks for the info @bobpeers :slight_smile:


#15

Hi,
How to set the scaling to 150% in the resolution, I am using windows 10 and the virtual machine is running on windows 10 too. I am using 1920*1080