Problem with screen resolution in production

Hi,

How do I ensure that the screen resolution from my virtual Studio PC is the same in the Production PC?

I have a process that works very well on my Studio, but when I publish it via Orchestor, it can’t even manage a simple “type-into” on a logon-screen on a web page.

Thanks in advance,
Søren

1 Like

Hey @Soren

Automation techniques may be sensible to resolution differences between the development and production environments.

There are cases when your automation may break or misbehave, depending on host and Virtual Machine resolution variations:

  1. For a smaller Virtual Machine resolution, elements might be rearranged in an application with responsive layout or elements may be left out of viewport if scrollbars appear

  2. For a smaller host resolution than the VM resolution, elements may be either left out if scrollbars appear in the VM window or they may suffer severe visual distortion if autoscaling is applied instead

By default, when a robot starts an interactive Windows session via Orchestrator, it uses the system resolution that the user configured for the machine.

If a custom resolution needs to be designated for the robot, You can make changes in UiPath.settings file on the system.
Uipath.settins file path_ - %ProgramData%\UiPath\UiPath.settings

t

Set the fields:

  • ResolutionWidth //E.g.- 1080
  • ResolutionHeight //E.g.- 1920
  • ResolutionDepth //E.g.- 32
  • if you connect via RDP you should have loginToConsole: false
  • if you connect directly you should have loginToConsole: true

Regards…!!
Aksh

2 Likes

Hi Aksh,

Thank you for your reply.

Seems like a good solution - I will test how it works on the robot…

Regards,
Søren

Hi @Soren,
How was the testing?
Did this setting work for you?
For me it doesn’t somehow :frowning:

Cheers,
J0sef

Bumping this.

Tried messing with all of the resolution settings on the PC in question and nothing changed. (same as @J0ska, sounds like)

Desperately need to override the standard res for this machine and nothing is working.

Is there another solution or better way to troubleshoot this?

Thanks

Hi Aksh,
How to set the scaling to 150% in the resolution, I am using windows 10 and the virtual machine is running on windows 10 too. I am using 1920*1080.

Hi Akash,

I am facing the same issue regarding resolution,I made changes in Production uipath.setting file but still not geeting expected result.

I am using RDP from my laptop,so should I enable and defauly LogintoCOnsole is true,should I make it false
please let me know what exactly LoginToConsole does?

Sadly not a solution, but just another report that changing the .settings file on the VM did not resolve this issue for me.

I ran a test process that grabbed the screen resolution and wrote it to the log and even after changing the .settings file, the logged resolution of the unattended session remained unchanged.

I am still searching for a solution that doesn’t involve re-developing my application library…

Hi Sanjay, I came across this on the LonginToConsole setting:

LoginToConsole flag makes a difference for these settings by establishing if the robot starts an interactive Windows session by logging to the console or by simulating a RDP session.

If LoginToConsole is true , the resolution is limited by the graphical card of the robot machine (which might be as low as 800x600 in some cloud environments), otherwise the resolution for a simulated RDP connection is restricted by RAM (which would generally be more permissive).

Source: http://madhuuipath.blogspot.com/2018/02/configuring-robot-screen-resolution.html

I faced similar issue earlier and it was resolved by following below
– “LoginToConsole”: false in Orch
– “LoginToConsole”: false in UiPath.Setting
– Check VM/RDP hardware configurations to allow higher resolution…

@aksh1yadav can we test this from orchestrator or studio or both?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.