Robot setup - Robot disconnected


I’m trying to setup a standard robot using Orchestrator as I am using the Community licence version and the robot I setup is always disconnected.

I have setup an environment and specified my project as the designated process. What am I missing here?



RobotSetupIssueUiPath.docx (217.6 KB)


Try provision with Studio Pro license not with studio

Also check from the studio machine that you are able to connect to orchestrator and showing status as connected, Licensed

This is not a bug report category, so don’t include Feedback and bug reports category while asking any question

Hope this helps you



Thanks for your response. I am using a Community licence version of UiPath so I could only choose the studio option. All other options gave me an error “no more licences/robots available”.

Also I don’t seem to be able to access UiPath robot from my windows start menu so I cannot check the machine and connect to orchestrator to see if it is licenced. Is there any other way?



Jeff … did you get this working ?

I am having a frustrating experience with Orchestrator.
(some bizare licencing restrictions)
My orchestrator settings say on my PC say that I am Connected & Licensed.

But when I create a robot in Orchestrator is says that it is Disconnected …
and there seems to be no way to connect it or change anything that might connect it. Driving me a little nuts !


Instead of replace with and try

Hope this may helps you


Hi @hughabbott

You’ll need to go to your automation cloud admin settings as per this link:

Once you’re there you should be able to activate an unattended bot licence so that you can set up an unattended robot to run automations on the cloud platform. Let me know how you get on.



@JeffNZ1 - thanks so much for your help - really appreciated.

I have finally managed to connect to orchestrator.
I had tricky problem …
in the bottom right corner of studio
I could see the ‘Robot Error’ light
but the orchestrator connection icon says you are connected (refresh)

the way i fixed was by running UiPath Assistant and ‘Signing Out’ from within Assistant.
You can see here that both Robot and Assistant had the same Orchestrator Configuration details.

Signing out from within Assistant magically stopped my problem.
… very crucial point … you have to sign out from the screen below.
( you can’t use the ‘disconnect’ button from within Assistant / Preferences )

But @JeffNZ1 … thanks again for your help.