Getting started - Cloud platform

Dear Community,

I would like to test the UIPath with Community edition and availability of Cloud platform, but Im having trouble getting Robot to work…

Are there a good guide, how to set up and configure the robot, so it works with Orchestrator? Or maybe someone can help answering, guiding to right direction about these issues:

I have latest Community edition installed and active account on I followed the basic guide and configured environment with default “Demo” process. I try to do this within enterprise environment with possible security restrictions.

  1. I configured my Robot with Orchestrator URL and Machine key, pressed connect, but it shows “Unlicensed”. Job I started is “pending”. I suspect, that connection is not established.
  2. I tried publish different process from UIPath Studio to orchestrator (My platform url is available as source), but it gives error, that Orchestrator doesnt have robot with my username.

I would like to achieve ability, to create process in UIPath studio, publish it to Cloud platform and then schedule tasks and run on unattended robot. Any assistance will be appreciated.

Can you post the screenshot of the Robot tray you have @Slowloris?

Below is image, hopefully it shows enough information.

You are not connected , can you post the screenshot of the robots page also @Slowloris?

Make sure, you have created a robot and assigned it to environment. The status should be connected before publishing the package,

This video will help you

Thank you for video, will check it and see, if I missed any steps.

I have created robots and assigned them to environment, below is picture of one example. Status does show disconnected…

I hope the username or something is missing, Are you sure your machine name is same as the robot tray and the Key in the tray is the one provided by the machines tab in orchestrator @Slowloris?

If your machine is connected successfully, then the status will be as below


Created new environment, recreated robots and machines, now it works… Dont know what helped, but creating everything from 0 was solution.

Glad you got the solution @Slowloris.

Happy learning :slight_smile:

Hi HareeshMR,

i have referred the below url for orchestration api:

i am able to call all api given there but now, question is now i want to run the process or bot the robot through external system using api.
May i know how to proceed further from here, because for every api i am getting unauthorized error even after using the access token.
Please help.
Manish Jawla

Are you sure you have the access token is not expired? @Manish_Jawla

Can you please try after getting the new access token using refresh token?