Robot does not exist

20.3.0-beta.84+Branch.release-v20.3.0.Sha.7fc79beda33f6ae9c6f407946cf052a16a3d7a0e
Robot does not exist.

RemoteException wrapping UiPath.Service.Orchestrator.Core.NoUserSessionException: Robot does not exist.  ---> RemoteException wrapping UiPath.Service.Orchestrator.Clients.OrchestratorHttpException: Robot does not exist. 
   at UiPath.Service.Orchestrator.OrchestratorClientExtensions.<EnsureOrchestratorStatusCodeAsync>d__3.MoveNext()

Hey guys I’m getting this error and I have no clue on how to fix it. I’m running this file directly from Studio.

1 Like

Hi @Sriganes96

Please try to run UiPath Agent Desktop on your machine

Hello friends,

Am also getting this issue, this error all of sudden came, everyday am working this issues just came today. Very frustrating, Kindly help.
Below is the screen short of REFrame Work Process.

Screen short of UiPath Robot & Orchestrator Settings

Screen short of Robot & Machine from Orchestrator

I gave up. Went back to 2019.10.4 version and it Works. And Now on I will follow stable path…. even those older beta versions worked fine.

Did you solve the problem?

No, not exactly @Pentti_Ristioja, still facing problem. I don’t understand what went wrong, since day before yesterday everything was working fine. Now am trying to create the new robot in orchestrator with new machine with now success.

I bet the problem is that newest beta version since earlier beta worked fine: Yesterday it updated automatically and problems came.

We cant do anything. I checked all I could imagine and more. So I went back to 2019.10.4. and it worked fine right after install. no hassle needed.

Do you mean this problem is just because of this beta version update? If I also went back to previous version then do you mean my problem will also solved? If yes then how can I went back, please let me know.

Yes indeed. Just go earlier version and all work fine. I went back to stable version. Just remove uipath and go
https://platform.uipath.com and there go to resourceCenter

Sadly you cant choose earlier working beta version, only last stable.

I wonder why you can choose earlier versions from stable but not from beta!?

With 20.3, you will have UiPath Assistant instead of Agent Desktop. Check to see what the status of the connection is. e.g. Is it Connected, Unlicensed?

Could not log in user to Orchestrator
image

Robot does not exist.
image

This can happen if the credential you have associated with the Robot does not match the user that is logged in or is not in a valid format. Make sure that is is domain\username or if you are not part of a domain then hostname\username. The screenshot you have above, the username provided being blacked out, based on the width seems to small to be a machinename\username unless your computer and user have very short name.

image

Also of note, if you are using Studio, the Robot should be of Type Studio and not Unattended.

I face the same issue with community edition license in my personal laptop.
The bot shows connected in orchestrator, But not able to connect to orchestrator from within the studio. UiPath Assistant says Robot does not exist.

image

Your username is not valid format. Please refer to my last post above or to the following post.

Thanks for the response @codemonkee. I have downgraded to the stable version on community edition, as I need to studio for now. I will test your approach and confirm in a couple of days.

Curious question though, with the same settings, my robot is connected to the lower version of UiPath. Is this something with the newer releases from UiPath?

image

This is what reads on the UiPath Agent Desktop :

image

It seems the issue is on the newest version of the orchestrator community version. Before last version you were able to Connect up to two studio robots to your tenant orchestrator and run both through jobs or triggers.
Since current version you’ve got 1 unattended, 2 attended and 2 studio robots that can be connected to the community orchestrator but only the single unattended robot can be run through orchestrator job or trigger. Unattended and studio are run only through uipath agent.
To solve the issue and have one robot run by orchestrator you should edit your robots and select unattended instead of studio. Of course only one at a time works, since you have only one unattended and the other robot appears unlicensed until you set free the unattended license

1 Like