Robot Crashes when Reading large Excel files

excel
studio

#1

Hi,

I am having issues with a specific workflow/.xaml file whereby the robot will crash at a specific sequence within the workflow. This only occurs on some occasions when running the workflow (other times it runs completely fine), and there seems to be no pattern as to whether the robot crashes or the workflow completes.

I have attached a screenshot of the error below- Selecting ‘debug the program’ brings up an error message within UiPath stating “Job ‘Name of Workflow’- stopped due to unexpected process termination!”. Exception type- exception. The error does not seem to appear in logs.

Update I’ve now found that the point at which the workflow sometimes crashes is when attempting to ‘read range’ for a sheet within an excel file- the excel file opens fine (I have visible set on the application scope) but the robot crashes when then trying to read the sheet range.

Kind regards,
Will


#2

I was having the similar issue with OCR and Read/Write to excel(high volume), the robot used to crash sporadically. I moved these activities to a separate workflow and the issue seems to have resolved.


#3

Hi Vinay,

I have tried putting it into a separate workflow and the issue remains.

It is a very large spreadsheet with a lot of data- are there any
alternatives?


#4

Few things I would try/think about:

  1. Can the data you are working with be broken up at all?
  2. Are you creating a separate thread when you are invoking your separate workflow? Tick the Isolated button on Invoke Workflow
  3. Are there any other resource intensive apps open at the same time such as Skype, Excel, Outlook - do they need to be open?
  4. What is the RAM on your machine?
  5. Are you using Excel Application Scope? Could you use Workbook activities instead to prevent opening Excel?

Richard


#5

A good test here would be to create a separate Test Workflow and see if you still get errors. If so then you know it’s the spread sheet causing the problem else it’s other factors.


#6

My project team is encountering the same error during the same point in our process (Read Range within the Excel Application Scope).

I think it is safe to say that this is a UiPath error.


#7

From what I can see the issue only occurs when I try to read a selective range within the Spreadsheet (e.g. A:T). When I read range setting ‘A1’ as the range- it reads the entire spreadsheet without issue. I’ve then used Datatable activities to get my selective range and this works fine.

I think that potentially when reading the selective range in the spreadsheet, UiPath is populating the datatable with far more rows than are actually populated in the excel. Moving the read range to its own workflow and using the selective range also crashed the roboot.


#8

Can the workflow/Excel files be shared? If not share them in a support ticket.


#9

I am also now a days facing a problem with latest stable release while dealing with excel scope and not able to read files till it is open.

Regards…!!
Aksh


#10

Has there been any resolutions to Read Range causing UiPath to crash? I’m helping a colleague who is experiencing the issue. Excel file is 1066 rows long with many empty rows. It works if we refine the range to only a few columns but if we choose too many or entire spreadsheet it crashes.

Thanks.


#11

Does it happen within Excel Application Scope and also with Read Range from Workbook?


#12

@richarddenton
I guess this problem was with excel application scope previous package versions to read some of blank rows it was failing but read range for workbook. It was working.Now a days its works fine.


#13

@richarddenton @aksh1yadav

It’s doing it with both Read Range in Scope and outside of scope. Also, the rows weren’t completely blank, but it did it even with the blank rows. I also tried Clearing the Content of all the cells outside of the data. The crashing didn’t happen on a smaller excel file.

I have only seen this problem now since we just updated to 2016.2.6379 which was needed to resolve an issue with Orchestrator RDP. Maybe the 6393 fixes it? Our link to install Studio did not give us that version though.

There is also another problem with Write Range now where it says Range does not exist that never was there before.

I have also tried rolling back the Excel package to an older version with no success.

Surely, we aren’t the only ones experiencing some of these critical bot-breaking issues, lol.

I guess we will create another ticket with support next week.

Thanks.


#14

I have also used with more then twenty k records and more.

Some excel package version sometime before was appeared but it was resolved for me or rest.

which excel version you are using? can i get that sample excel to check if data is not that much confidential? in PM? if you can share.

:slight_smile:

Regards…!!
AKsh


#15

Hi thanks for replying.

Older version of Excel Activies I copied from a machine not being used for development at the moment.
UiPath.Excel.Activities.2.0.6361.22986

Newest version that was being used when the problem started coming up:
UiPath.Excel.Activities.2.0.6382.14545

To me, it seems like it’s related to the Studio update, not the Activity package.

I think I would need to ask the owner permission to send the Excel file since it’s not my file. I might try and duplicate the issue with another file of similar size. It’s the weekend though and so I might not get to to doing that til next week :stuck_out_tongue:

Thanks.


#16

Hey @ClaytonM

haha sure enjoy your weekend :slight_smile: may be but same version i m using of studio :slight_smile: hope you will find something may be that will be useful for me as well :slight_smile:

Regards…!!
AKsh


#17

I’m having the same issue, reading a xlsx file with 300 000 rows in it. Robot Crashes in a few seconds.
The file is quite big, even when I open it manually it takes a while to load.

Any solutions yet?


#18

Have we got any solution for this problem??

Regards,
Arun


#19

Read it in chunks:


#20

Thanks. I’m adding data from several excel files into a single excel file.

Another solution I came with was to make a macro that will cut and paste data from a file to another.