Robot Crashes when Reading large Excel files

I am facing same error when loading excel file with data of 54K rows and column till - FD.
This is not the file issue.
Till now it is looks like UiPath limitation of not loading large excel file. This is a show stopper for our project now which I am working.

I have written a C# application to read the same file and loadinf data to datatable which is working fine.

Please give some solution.


Are you using Output data table for the final large table this causes the issue. try writing the data in sample excel rather than using output data table if you are using any.

I am reading 1000k rows from same excel…anxd it is working so fine…

Large file load is working if there are 8 GB RAM. My PC has 4 GB ram and here the large file is not opening. But it is opening from laptop where it has 8 GB RAM. Not sure if this is the actual reason.

1 Like


I am getting “UiPath robot stopped unexpectedly” from the Connect Activity when i am establishing connection to the input excel file. I have my input excel file and UiPath Studio in the local environment. But the application I am working on is inside Citrix.


I m not sure i understand your scenario, can you send me a sample wf?

Main.xaml (33.4 KB)

Sure. Please find the attachment. I have my Connect activity in the Retry scope. I have used disconnect activity at the end of the process which i haven’t shared here. The error is arising only from the Connect activity when i tried debugging.

Also attaching the error message with this.

Hi did you get any solution for this ? I’m also facing the same issue .

Try increasing the WCF channel size :

Hi, I have already tried this. My machine is not connected with the orchestrator. The Bot tends to run sometimes and sometimes it randomly fails at a particular step, without logging any error/ exception.

I have also tried splitting the step in submodule and marking activities/invoke as private. It also didn’t work.

The link I sent you actually contained an error, wcf is not the channel between robot and orchestrator, it’s the channel between robot service and executor. It was fixed now.
Is there anything logged, when the job fails, in event viewer ?
Can you enable low level logging (cmd > UiRobot.exe --enableLowLevel), try to make the flow fail again and see what is logged in event viewer ?

What version are you using?

Hey andreiT I am unable to find the maxReceivedMessageSize in my UiPath.Service.Host.exe.config file. I am running 2020.4.1 sutdio. Would the version of my studio affect where the maxReceivedMessageSize would be?

Hi tamim,
That is correct, in 2020.4.1 we are using another custom channel to communicate between processes, not WCF, so that option is not longer present.
Do you have problems processing a large file ? Can you explain your problem in more detail ?

Ah okay, that makes sense

Yes I am unable to open a .csv file that is ~100 KB in size. but when I convert the file to xlsx I am able to. I was hoping that resizing the maxRecievedMessageSize would fix this. Would you have any other suggestion?

100KB is small actually. Even the old WCF channel would not have trouble with it.
I think the problem has another root cause, maybe the CSV extension itself. Or maybe the activity you are using does not allow opening of CSV files.
Can you post the actual error? Maybe we can pin point the error origin.

Yeah sure the error I get is
I am using Read CSV

That is definitely a csv formatting problem.
Check this thread out, I see people had this problem in the past:

One solution that seems to works is opening the csv in excel and saving/exporting it as csv again.

I will have a look at it thank you @andreiT

1 Like

Do we have any solution for this yet?