Excel Application scope stopped working abruptly

Scenario: Use excel application scope , read range/write range activity

Steps to reproduce: Create a dummy excel with some data. Use excel application scop activity and provide the path of the excel. Use read range activity to read the data from excel.

Current Behavior: The bot hangs on reaching the excel application scope activity.No error is thrown,nor does the bot stops.It needs to be manually stopped. The excel application scope was working as expected until few minutes back and stopped working when tried running later. Is this due to some security patch of excel?

Expected Behavior:The excel application activity should go through as expected.

Studio/Robot/Orchestrator Version:2016.2.6344

Last stable behavior:
Last stable version:
OS Version:
Others if Relevant: (workflow, logs, .net version, service pack, etc):

2 Likes

Hi @sucnayak

Could you please check if there is any update for the Excel package? Manage packages -> Update

Hi,
How about “Read Range” activity under workbook tab.

readrange

I am also facing same issue. I have to open at least 20 excel files one by one. But unfortunately, uipath stops working during read-range activity with error message “Uipath robot has stopped working”. Can somebody help me in this.

1 Like

Hi,

Facing the same issue while trying to read Excel file using Read range activity in Excel application Scope. It was working fine before; before some days back it started giving error as ‘Uipath robot has stopped working abruptly’. Sometime it’s working but getting error once in a while.
Excel activity that currently in use : 2.0.6479.13204

Anything related to Excel Activity package ?

Please try with below methods to resolve bot crashing issue:

  1. Do not keep multiple Excel scopes in single workflow where all the excels are reading huge amount of data . It crashes because of memory which can be seen in Event viewer as well
  2. Keep these excel scopes in separate workflow and check in “Isolated” property of all the workflows
  3. Check if any data table arguments is not used both as “In\Out” direction. It should be either used as “In” or “Out” at a time

Check all of above three. It should work.

1 Like

Can you provide any reason for your suggestions?

1 Like

Hi I’m also facing the same issue. Can you please help.

Did you get any solution for it ?

Ha?
Any Detail Explanation?

Hi,

Did you find the solution to this?


Hi,
Seems Excel Application Scope stopped running.
It does not show any error. Just stalled and waiting forever, without entering the Excel activity.
This is happening either in Run or Debug mode.
Windows 10, Office 2019, UiPath Community Edition 2019.7.0
Any advice?

I’ve experience this issue once, it was when the excel.exe crashes but it stays on the windows task manager. Could you check if there is excel.exe stuck in task manager? kill it first if you have to.

1 Like

I did a full restart.
The issue remains the same.
Solved by repairing MS Office.
Strange.

1 Like

Indeed, a stop of the stuck Excel in task manager solves it.
Thanks beantony

A post was split to a new topic: Excel application scope has stopped working with the following error: 0xC0000005