UiPath Excel Activities (Read Range)?

Hey folks!

I’m facing some strange issue with Excel Read Range activity.

I’m trying to read all sheets in one workbook. I’ve trying it by using read range activity sheet per sheet (some workbook files has more than 5 sheets then I’ve to get it more than once time), ok, of course there are another better ways to perform it, anyway, ok it’s working…

However, I dont know why, but in some cases the read range activity become big slowly (about 3 or 4 minutes to read all sheets) and another just 20 seconds… We tried to test with a lot of excel files and the same issue…

Excel App Scope -> Read range activity (sheet contains different kinds of data type, number, date, string and others…) -> Get it all in DataTable. Sometimes fast (20 seconds), sometimes slowly (3 minutes). The files are almost the same, but not equal in terms of datatype/number of sheets. Is possible to exists something wrong with datatype reading? (I mean from Uipath activity processing side)

It turns out to be funniest, because it was working correctly / faster 1 month ago, and we have not updating anything in the code. I don’t know if Uipath update something with that activity but still don’t find a workaround for my situation.

Did u already experienced the same issue? If yep, please share!!!

Thank you in advance

Hello @Felipe_Kotinda

I think I came across the same scenario few weeks back. In my case I was reading about 25 columns and about 300 rows of data. It was pretty slow. In your case, what’s the volume of the data we are looking at? In each sheet?

Hey Lahiru!

My case I don’t get much lines / columns (about 15 columns / 100 rows),

What did you do to solve this regarding your case?

Hi @ Felipe_Kotinda,

and you are reading this files from a computer folder or a shared folder ?

Else, can you see if you machina have some update from microsoft in last month ?

Tnhx

1 Like

hmm
it can be due to memory issue…as that could be the only one which varies from time to time.
As you say the excel is getting processed one time much faster and another time bit slower.
–so i hope during the time when the bot runs slower is beccause of the application been used for long time or one or more application of excel is used while this process is executing, that would reduce the speed of the process…

–for that we can use KILL PROCESS in the beginning of the process that kill all the required application involved in the process like EXCEL, pdf or any other appliication but especially EXCEL.
–and in kill process activity mention as “EXCEL” for the property PROCESSNAME in the property panel

and to know the process name of other applications go to TASK MANAGER and get the process name without .exe extension

that could help us increasing the performance of the bot execution

Cheers @Felipe_Kotinda

1 Like

@Felipe_Kotinda @Palaniyappan

In my case it is not a memory issue. I’m not sure the reason. But in my machine which I tried it’s a computer with a very high spec on hard disk, memory and processing power. Still it was slow and there were no other high memory consuming app running in the background. The files were in a local folder too…

I didn’t have a choice other than using the read range…

awesome
yah you got the keywords,
even when we were facing this issue we placed the file in a local drive (with less memory used) but the thing is the process was using excel application one next to another continuously like the process had too many excel file accessing…so at one point literally to speak cpu didnt smoke away :smile: as it involved many integrated applications: …it got stuck and just we placed kill process and some places with CLOSE WORKBOOK activity that helped us on that
and even we used delay at certain points…that helped us too

even we are still wondering why that happened
maybe there could be some reason with server…but thats how the issue was resolved

Cheers @Lahiru.Fernando @Felipe_Kotinda

3 Likes

Hmm… that method sounds interesting… let me give a try on that too … I’ll tell how it goes in mine… may be tomorrow

1 Like

@Lahiru.Fernando @Palaniyappan @Felipe_Kotinda

I also faced this kind of issue. For this, i did like created one workbook variable for Excel application scope activity and then used Close workbook activity and passed that workbook variable ro close the opened excel file and it should be after Excel application scope. It should work perfectly without any issues.

5 Likes

Do you have the PreserveFormat enabled in your read range activity? Or Visible/ReadOnly in Excel scope activity?

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.