Robot could not run properly on VM

HI there. I have deployed an unattended robot on a virtual machine. It ran properly when I logged on (remote desktop connection) and clicked run at the robot tray, but when I disconnected the VM and tried to run the robot from the Orchestrator (Run Job), seemed like there were some errors on activities like Type Into, Click (Timeout reached) and also Take Screenshot didn’t work. Looked like it could not detect elements on the screen.

Things I’ve tried:

  • Specify the VM’s screen resolution on robot setting (in Orchestrator).
  • Use ‘Invoke Workflow Interactive’ and specify the resolution.
  • Set ‘Login To Console’ to false.
  • Restart the robot.

Anyone has solutions? Please help.

Thank you.

Hi.

I had the same issue very recently and tried the same things as you. I was doing a lot of work, inside a Java application, and many of my Click actions failed / timed out.

I assume the robot is licensed with an Unattended License (if not, that would be why…)

I then launched Remote Desktop with the same screen resolution as my robot settings in Orchestrator.

When running the process from Studio in the resolution, it noticed some things were different from when I normally ran my RDP in full screen. Clicks were not accurate, and I managed to adjust the X and Y offset and get things to work this way.
image

Not sure if this applies to your issue, but it could be worth checking…

Another thought is about security. Are the credentials you are using for running the unattended robot the same or different from the ones you use when running from the tray? If you have a service account, there are some things that need to be setup for it to work. Please see this for more info: https://docs.uipath.com/robot/v2018.4/docs/installing-the-robot#section-prerequisites

Hope it helps :slight_smile:

Best regards,
Michael

You could try https://connect.uipath.com/marketplace/components/robot-streaming
It “broadcasts” the robot’s screen so you could watch what’s going on in the unattended session.

Cheers