Error running robot on remote desktop unattended

So I have built a robot in a remote desktop on Windows Server 2016 as local admin.
Running the robot with a screen showing its execution, work perfectly fine. Problems arise when I schedule the robot to run unattended.

I run a batch-script using Task Scheduler, and things work fine until the robot, in the middle of the execution, fails to click buttons and type text into the desktop app it is working in. Simulated clicks and simulated typing work at some places. The main issue seems to be where clicks are not simulated.
The target for the click is what has always seemed to be a stable selector. Unfortunately the SimulatedClick property can not be used in parts of the process.

I have tried the SendWindowMessages property without any success. I know that my robot is sensitive to changes in resolution, and that this has been an issue for others. In my case, the right resolution is forced using Powershell, changed in the UiPath.Settings-file, AND filled in InvokeWorkflowInteractive-activity.

So my question is if anyone knows what the issue could be? Or anything else that can differ between running the virtual desktop attended versus unattended. Could the scheduled task or script be an issue despite the fact that the robot starts running? Could it be a question regarding restricted access?

Any help is very appreciated.

Hi @Sebastian0978,
Welcome to the Community!
The problem is that when you are using unattended robot all actions which rely on visual elements are not visible for the robot. You can consider use of Computer Vision package and it’s activities. This should solve most of problems like this.

1 Like

Sebastian, you need to use Orchestrator to run this job. Task Scheduler isn’t supported by UiPath. Your robot needs to be logged in and with the screen showing in order for this to run. Orchestrator is easily able to automate this. Otherwise, you’ll just need to make sure the Robot is always logged in to the PC.

1 Like