Unattended working only when the screen is open

Hello all,
I am facing problem that my unattended robot runnung from Orchestrator works fine, when I have opened target computer window (via remote desktop), but when I am running it from Orchestrator and computer window is closed it end up in the error - “Could not find the user-interface (UI) element for this action.”

I went through the forum and found some hints -

  1. Try after making these changes on the robot settings page. Set ‘Login To Console’ to No and update the resolution width, height and depth. → this one I did with the same result.

  2. Install UIPath as a Service mode. → I am using UI Path Community edition which doesn´t have this option in the installation. How to solve this? On the forum I found that I should download Enterpise edition for this option but then I have only 60 days and then had to upgrade my subscription, right?

Do you have any other tips what settings should be changed?

Many thanks.

@Lukas_Nebohy_KA If you have opened the remote machine in-between the bot run the bot will throw error if you have closed in-between. This is because you are running an GUI based process, so when machine has been opened in-between, the machine will be in foreground so the bot will be automatically recognizing as foreground run. I would suggest not to interpret in-between for GUI based processes.

Hello @Lukas_Nebohy_KA

I guess unattended robots cannot be fully utilized with Community Edition.

You can try finding a solution which will keep your remote desktop awake all the time.

An alternative could be minimizing the RDP, here’s the guide on how to make your robot run with minimized rdp:

1 Like

Hello @Lukas_Nebohy_KA

Have you checked the below documentation?

Deploying Unattended Robots - Community License.


Hello @Rahul_Unnikrishnan

I checked the documentation and did the same process with few differences (I use Stadnard machine in stead Template as name of the machine is every time same and I use Robot account instead User account.

Thank you.

Hello @GT_Ropa

Thank you for the hint, I tried this registry settings on the computer I am connecting to remote desktop but with no result. I guess I can solve this RDP issue separately. But if I am understand your point correctly, also when minimized remote desktop have connection have to run at some computer all the time, right?

Thank you.

Exactly, your RDP needs to be running on some remote computer, you can just log into it with RDP and start your AR then minimize the window.