Resolution settings / UiPath.Settings File resolution configuration / runtime resolution - unattended configuration - How To

please make sure the proper resolution setting has been defined i.e. height, width & depth

Approach 1# : Latest Version Of Orchestrator

please make sure the proper resolution setting has been defined i.e. height, width & depth

Approach 1# : Latest Version Of Orchestrator

The below snapshot shows the configuration done in one of the machines for the Robot to execute in unattended mode with a specific resolution. The resolution is taken from the dev environment where workflow was developed and applied on the Robot machine in UAT/ PROD environment.

Enable Login to Console and set it to No, (which means false)- similar to below.

Enable depth & provide the value as 32,

Also, the resolution which you have defined should match the resolution of your development machine where the process was developed.

For Example: In my development machine, the display is 1920 * 1080 thus I have provides value as such.

Before applying to make sure you crosscheck your resolution settings.



Approach 2#: Changing the UiPath.Settings file for the older version of orchestrator (resolution configuration is not available)

How To - Setting up Resolution # :

Development machine from the studio:

  1. In the development server:
  • Use the “Take Screenshot” activity. Using this activity, do not select anything on the screen, select the entire desktop.
  • Use “Save Image” activity to save the image at the desired location.
  1. Check the details tab in the properties of the image saved. Note the depth, height, and width.
    Once you have all the details, Login to Orchestrator and change the Runtime settings(Resolution Width, Height and Depth) for the Robot which is running as mentioned in below screenshot -
    Robot machine:

  2. Login to the robot machine.

  3. Open uipath folder under program data. Add in UIPath.settings(path : %programdata%\UiPath\UiPath.settings) file the height depth and width that you have noted in the appropriate parameters. Logintoconsole: false (small f)

  4. Restart uipath robot services (Run -> services.msc -> Uipath Robot -> Restart)

  5. Reboot the machine.

  6. Logoff from the system.

Once you follow the above steps then check if you are able to run the job from Orchestrator in unattended mode and share the outcome.

Note:
Make sure to logoff/Sign off from the Robot machine rather than disconnecting.
You can apply the setting in either Orchestrator runtime window or on Robot UiPath.Settings file.
The former overrides the settings of the later.

6 Likes