RemoteException wrapping UiPath.Core.ElementOperationException: Timeout reached

While trying to run a process locally, it runs smoothly but when I try to run it from orchestrator cloud, it gives me following error:

RemoteException wrapping UiPath.Core.ElementOperationException: Timeout reached. —> RemoteException wrapping System.Runtime.InteropServices.COMException: Timeout reached.
at UiPath.UiNodeClass.BringIntoView()
at UiPath.Core.UiElement.BringToForeground()
— End of inner exception stack trace —
at UiPath.Core.Activities.ScopeActivity.OnFaulted(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.Invoke(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.FaultWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

I have attached my xaml file for reproduction as well. I followed this topic and tried to change the resolution to 1920x1080 (which i identified by screenshot method as sugggested here) but that didn’t work as well. Kindly let me know if someone has faced this problem in past and found any solutions.

What I found is that when my remote desktop window is open (inside my local machine in minimized form) the process runs, but when I close it (even though the machine is on) it halts giving the above error. When I run it manually from the machine, then also the process runs smoothly.Main.xaml (10.8 KB)

Hi, Is it a Server or normal windows? Are you logging off or simply disconnecting the manual session? Disconnecting the session won’t remove the current session. Sign-off all the manual sessions of your user(there can be multiple in a server depends on license) and try to trigger it from orchestrator.

It’s a server and yes I am just disconnecting the remote session. Here is the screenshot for the same:
image

Were you able to resolve the issue after signing off?

No @JithinKP It still throws the same error.

@spidey - Can you post a screenshot of your Robot Settings from Orchestrator? Please confirm if you have done the following,

  1. Sign out manual session (not disconnect)
  2. Login to Console - No
  3. Update Resolution Height/Width/Depth same as development machine’s details.

In between the process, if you close/minimize the session unattended process will fail anyway with GUI. Either we need to keep it open completely during the run or keep it closed completely during the run. We need to figure out the second part now if I am not wrong.

I have updated Height Width, but not sure about how to update the Depth.

@spidey - Take a print screen from your development machine and check the properties of your screenshot. Depth will be there.

Thanks it worked!

Awesome :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.