Publishing the project has failed

studio
publish

#1

When i try to publish a project on UiPath Studio Trial, i get this error Capt1111ure
I can publish a project on UiPath Community Edition but i don’t know why it doesn’t work on Studio.


#2

Did you check if you have some test xaml files that are incomplete or not working in the project folder?
If so it will not publish. You can also check the log for the error.


#3

But if something is incomplete or not working, why on UiPath Community is working? I can publish from there and then run a job from Orchestrator, so I think there is a problem on UiPath Studio version.


#4

Did u update to 2017.1.6407? I had some problems with the previous build


#5

On UiPath Studio Community i have 2017.1.6407. How i can update to this version on UiPath Studio Trial? When i click on Help, it doesn’t show that there is a new version and i should update.


#6

UiPath latest edition was UiPath v2016.2.6393.
v2017 is for CE not for Studio.


#7

I have 2016.2.6379 on UiPath Studio Trial but it doesn’t show that i should update to 6393. Is there any download link?


#8

Yep .Even though there is update available it doesn’t show up in the help tab . Earlier I used update new version from HockeyApp for UiPath site but now its been made private i guess.
Release note tab only let you know about version but there is no link to download.
@badita


#9

So is there any work around for this? @badita


#10

You should be able to switch to the beta channel from stable. Let us know if it works.


#11

I can switch but nothnig happens, i restarted the app and it shows the same version 2016.2.6379, but i checked beta.
Capture


#12

and still no update available…
ok, that’s a bug.


#13

Thanks but that is Community Version. I need Studio Trial because there is the problem, not on the Community one.


#14

It’s not community. It is beta trial.


#15

For me this turned to be an issue with the json file related to changing versions. To resolve it, I created a new project with the exact same name in a different location and copied over my original files.


#16

Hello, I am using v2018.1.2 Community Edition and facing the same problem suddenly. It was working literally 3 minutes ago and now it doesn’t. I am getting below error. I tried creating project in different folder but still it doesn’t work. Strangely, I am connected to UiPath Orchestrator and can even retrieve the value of an asset stored there. Issue started when I tried to publish this small project, not able to publish any project now. If anyone has knows the solution by now, would appreciate a lot.


#17

Just an update that this issue was resolved. I closed UiPath Studio and Orchestrator along with UiPath system tray; restarted everything and the publishing problem was solved. Not sure why the problem started in the first place


#18

Hi,
I am trying to publish my first robot but i am getting the below error while publishing the project. it is simple project with only one message box.

Error: The message with Action ‘http://tempuri.org/IUiPathRemoteDuplexContract/GetPublishInfo’ cannot be processed at the receiver, due to a ContractFilter mismatch at the EndpointDispatcher. This may be because of either a contract mismatch (mismatched Actions between sender and receiver) or a binding/security mismatch between the sender and the receiver. Check that sender and receiver have the same contract and the same binding (including security requirements, e.g. Message, Transport, None)


#19

Hi Vijay,

I faced same issue last month, I just closed UiPath Studio and Orchestrator along with UiPath system tray; restarted everything and the publishing problem was solved. Not sure why the problem started in the first place.

I hope same works for you too. You can try it out.


#20

Hi Nitish,

Thanks for your response. i did try all the options closing and restarting all the servers/studio but no luck. I am trying to publish the project to https://platform.uipath.com/robots from my local machine so not sure any additional setup needs to be done.