Publishing the project has failed error


#1

Hi,
Can anyone help me solve this error message please. The project was working fine till yesterday but today, I started getting this error message while trying to publish the project. Thank you.

error


#2

Hi @suwalruchan365,

  1. Check it.The other xml file which you are using inside the main xml has error or not .
  2. If the robot.exe is running, verify it the robot and the studio are from the same version. And the both paths should be from same directory.
  3. The Final developer solution is uninstall and reinstall the studio.

Regards
Balamurugan.S


#3

I checked all the checklists you mentioned.

  1. The project is running smoothly and completing assigned task without any error.
  2. robot.exe is running and robot and studio have the same version 18.1.3.0
    So, I think I will have to go with reinstallation.
    Thanks for your suggestions. I will let you know once am done with the reinstallation.

#4

Hi @balupad14,
I just figured out that the error was due to version difference. I realized there was two different UiStudio.exe available. One in the main Uipath Directory and the other one in “UiPath\app-18.1.3” directory. The former UiStudio.exe had a different version i.e. 18.2.1.0. So, I run UiStudio.exe from “UiPath\app-18.1.3” and tried publishing the project. And it worked well. Thanks for the solution.