Job State stuck at Pending

Hey,

I am trying to run a process from orchestrator but it is always in the Pending state. I am using modern folders. My robot and my machine are connected and available.

I tried deleting the machine and creating a new one. I tried creating a new robot, but it didn’t work.

The only thing that is working is when I disconnect my machine from Assistant and connect it back. When I do so, the pending process will run. Otherwise, it won’t.

I’m using the community edition.

Thank you.

Hello @Charbel1!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly
Forum_Staff

I had the same problem

What it worked for me was to:

  1. Run the process (process remains in pending)
  2. Disconnect robot from UiPath Assistant
  3. Reconnect robot from UiPath Assistant
  4. The job starts automatically

Yes, exactly, this works, but it works only once…

We need a consistent solution.

I am having the same issue. Using 20.10.6 for Studio and Assistant. I was forced to use Modern folders because legacy folders aren’t available. I can successfully run my process manually from Studio and from Assistant but Orchestrator Triggers and running the process from Orchestrator manually keeps it hanging in pending status. Interestingly enough, the “Automatically Start Process” function works as expected when the assistant starts. Again though, the automatic triggers as well as manual running of the process don’t work inside of Orchestrator. I have ensured my robot assistant says Connected and licensed. My machine and robot show up correctly in orchestrator.

I am having the same problem as @mark.dangio
I have feeling I tried literally anything.
I am also confused from the Tenant - Robots - I cannot delete “Robots” or create…
I use community edition orchestrator, modern folders, most up to date Studio.

yeah that worked for me aswell, dont understand why we need to reboot the assistant

For me the “solution” was to create another community Orchestrator and automatically has a newer version and the bug is not reproducing anymore.

Hi,
i had the same problem before. you need to go to Tenant folder and edit the username. Go to unattend robot and enter your domain/username (getting it from Command prompt:Whoami). remember to enter Domain\username

hoping this will help.

2 Likes

If anyone comes over this threat, here’s a detailed solution for it:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.