Job Pending - Does not start

Hello,

I searched the forum and documentation for related topics and could not find a working answer.

Need some help to start unattended job on my personal computer using Community Cloud and Community Studio.

This used to be relatively simple on classic btw. Now I am using the machine template and signing in with an authentication service (Gmail). I can’t figure why the job does not start on my windows session.
No error message, the job just keep pending forever (or pending allocation if no machine provided).

My user:

My machine template:

Machine on the Folder:

User on the folder:

Triggering a job:

Job is always PENDING.
The only way it works is if I start it manually from the Assistant.

Availability from the Tenant robots:

Any help would be appreciated.

Thanks in advance!

Hi
Can you show us the screenshot of robots if possible

Cheers @Thiago

Sure!
Here you go.

Thanks!

Is it tagged to a environment @Thiago

Hi, I could not find Environment tab when using template. Searched all over the place, I assumed that it is deprecated when using machine template.
If I am missing it, please help me locate it.

As an update, I was able to make it work fine using a Classic Folder.
But that is not what I am aiming for here. I want to use the modern folder.

Can someone help me track down what is wrong when using a machine template and connecting the assistant as service?

Hi @Thiago,

Could you also check role permissions assigned?

Do you have below permissions enabled for your user at tenant level?
image

And below ones at folder level?

Furthermore, please check if unattended/non-prod license under Licenses tab is active?
image

Regards
Sonali

Thanks @sonaliaggarwal47 for the reply.

I checked your investigations and there is something weird on the licenses.
The roles are all good (checking for Administrator Role which is assigned for my user).
However in licenses it is stating the unattended with the amber dot for “unlicensed”.
(While attended Developer license is green)

I checked the licesing from automation cloud and there is 5 available, and there is only one Orchestrator Tenant on my cloud environment.

How to make the unattended licensed (green) considering I have 5 to use:
image

Thanks in advance!

Hi @Thiago ,

This license needs to be green in order to be able to run process succesfully.

I noticed in your screenshots, you have assigned non-prod as well as unattended license for same user/machine.

Is there a specific reason for this?
As non-prod license is used for unattended exceutions in non-prod environments while unattended is required in prod environments.

Could you please try to just keep 1 enabled and then refresh and check license status for the one enabled?

Regards
Sonali

Hi @sonaliaggarwal47 thans again for replying
I removed the Non-prod license from Machine and it had no effect on licensing.

EDIT:
I was able to make it work following a few steps:

  1. Delete any current machine template.

  2. In my user profile (generated by Service Authentication) disable Attended and Unattended robot options.
    2.After doing that, in the user list should say:
    image

  3. Sign out the UiPath Assisstant (it should be unlicensed by now)

  4. Back to user profile, re-enable the Attended (Citizen Developer) and Unattended options, also enabling to generate a personal workspace (this will add a machine template automatically).

  5. Sing in the UiPath Assisstant.

The rest is the same:
assign a unattended license to the new machine template, and assign the user and machine to the folder you want.

Done.
I hope this can help someone in future.

Thiago Oechsler

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.