It is not possible to communicate with the browser. Check the UiPath extension

Hi there

Snce the last update to version 2021.4.0, i am not able to comonicat with the browser chrome.
it is in português
image

I alrady try all the solutions posted here:

And also instal the extention by CMD
image

The configuration of the extention of chrome:
image

And the error message afther using the uipath activity “Open Browser”:


image
image
image
image

Please can any one help me with this error?

Hi @Mario_Gomes_Moreira_WINNI , Welcome to UiPath Community. You can check the below link and see if you can get a solution from there.

Learn how to fix the UiPath Chrome extension error.

Best,
Robin

Hi there @AKM_Robinuzzaman .

I managed to following the instructions, but at the last step, the ChromeNativeMessagingHosts dos not working.

the “Console Window Host” and “Windowa Command Processor” start’s, but then it disappears.

I also did follow this instructions:

but wen it come to the second step to edit the Police

I dont have it

And for some reason, my Registry Editor create a second key com.uipath.chromenativemsg_v2

Any idea why?

Hi there.

I have update,
Now it seems the “Chrome Native Messaging Host” is running on google side

But still the uipath is not working. And the extension is producing error messages

Need help :frowning:

Hi there.

Update on the problem.

it is solved (I don’t know what i did to work)

I have been reding the cod of the extension, and by the name of the key, it wasn’t the same as the crx_manifest.json


And remove the extra key that i’ve created
image
Rename the key to end as “_v2”

Remove the Uipath extension and end the google process on Task Manager and restart the Uipath studio.

Instal the extension

Open the browser and activate the options

But still i’m not sure if it was all this that put the activity to work with google browser.

In fact most of the Chrome Ext install come from restrictions/policies/controls of our organization that manage the OS. (it is rarely show the similar issue with your own PC at home).

I may start with my general setting which might give you and others.

    1. Make sure that no restriction in the
      \Software\Policies\Google\Chrome\NativeMessagingHosts\ExtensionBlacklist. If you found any thing in this session, it means ‘Block’. ‘*’ = block everything.
    1. In case there is ExtensionBlacklist, then you may allow you extension to be installed. By having the specific extension’s ID added in ‘Software\Policies\Google\Chrome\NativeMessagingHosts\ExtensionInstallWhitelist’.

Step 1) and 2) go together - you won’t need to add the Whitelisting if there is no Blacklisting.

    1. Once you have installed the Chrome Extension, the extension reference would show up in \Software\Google\Chrome\Extensions… where it shows the ID, version, and .crx file path.


If you don’t have the ‘Extensions’ show up, it doesn’t interfere the functionality that much - you can leave it be.

    1. The NativeMessagingHosts is a must. The referring registry, manifest file path, manifest file’s content are linked accordingly.
  • 4.1)…\Software\Google\Chrome\NativeMessagingHosts… must have the reference of ‘com.uipath.chromenativemsg’ (name for reference). The registry value must refer to the ‘manifest’ file path.

  • 4.2) In the ‘manifest’ file that is referenced, the content has to have :
    “name”: <the ‘com.uipath.chromenativemsg’ name from the registry>
    “path”:
    “chrome-extension://<Chrome extension ID - version that you installed>”

If those relations are linked properly, the ChromeNativeMessaging should be able to enable and run.

Though I still use Uipath v2018, but the principle of how Chrome works would be similar.
The missing registry can be added manually with admin. Also i use HKEY_Local instead on _Current_User, but the idea of referencing NativeMessage doesn’t change.

Hope it helps
Thanks

@Mario_Gomes_Moreira_WINNI thank you for reporting this. We have fixed the issue and is available with the next 21.4 both Stable and Preview releases.

2 Likes

Hi @gheorghestan ,

Do you have any news about this issue in the version of 21.4? Is it fixed in the version 21.4… Because we are also having this issue …

Regards
Balamurugan.S

Hi @balupad14 . Yes, it’s fixed. Please update the UIAutomation.Activities package to 21.4.4.

Best regards
Gheorghe

1 Like

Thank you @gheorghestan.