Open Browser Cannot communicate with the browser, please check the UiPath extension (Google Chrome)

Installed the latest licensed version of Uipath Studio i.e. 2018.3.2. Also successfully installed the Google Chrome extensions from the tools option of Uipath Studio. Can also fetch the selectors of the UI Element from the chrome browser.

However every time I run the Bot to test the workflow, am getting the following error

"Source: Open Browser

Message: Cannot communicate with the browser, please check the UiPath extension.

Exception Type: UiPath.Core.BrowserOperationException

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
UiPath.Core.BrowserOperationException: Cannot communicate with the browser, please check the UiPath extension. ----> System.Runtime.InteropServices.COMException: Cannot communicate with the browser, please check the UiPath extension.
at UiPath.UiBrowserClass.Open(String bstrURL, UiBrowserFlags flag)
at UiPath.Core.Browser.Open(String url, Boolean privateSession, Boolean headlessSession, Boolean defaultSession)
— End of inner ExceptionDetail stack trace —
at UiPath.Core.Activities.ScopeActivity.EndExecute(NativeActivityContext context, IAsyncResult result)
at UiPath.Core.Activities.AsyncNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)"…

Searched the forum and tried everything like uninstalling and reinstalling the chrome extension, restarting the browser, etc. but nothing works. Please assist me with the same as I am stuck at the project at this phase.

Regards,

Nisha.

2 Likes

Hi @nishakankaria
does your process work for one time right after you install the extension?

1 Like

No, it doesn’t work at all. Not even once.

1 Like

I’m having the same issue. It’s working on 2018.2.3 but when I update it to 2018.3.2 it gives me this error.
I also have the chrome extension and already tried to restart the machine but still the error exists.
Please help.

1 Like

same error on version 2018.3.3

1 Like

Hi,

I already figure out the problem on my end. I installed again the UiPath 2018.3.2 then select change
then
image
choose Entire feature will be installed on local hard drive.

It works on my end.

4 Likes

I am facing the same issue.
I am using UIPathStudio 2019.2.0 and Chrome plugin version is 9.0.6421

I tried to reinstall the plugin via both UIpathStudio tool menu and Chrome extensions store,
I tried to reboot the machine, …, flush the browser cache…, but still not working.

I don’t know what to do now :frowning:

Any idea ?

2 Likes

Hi all, …same thing is happening to me:

I’ve tryed to install de extension via UiPath installer, UiPath Studio and command line… and always says “UiPath Chrome extension was installed…”, but it doesn’t!
I’ve tryed uninstalling Chrome and reinstalling it…
I’ve tryed to uninstall Studio and reinstalling several versions (18.3.2… 18.4.0… 18.4.2… 19.4…
I’ve tryed to update Java…

It is not working no matter whatever I do! …the extension it is NOT shown on chrome://extensions

Current Chrome: Versión 74.0.3729.169 (Build oficial) (64 bits)
Current Studio: 2018.4.2

Any idea or help?

thnks!!!

I’m getting this error during mid-execution. The robots opens up a specific page and extracts href values in button. I achieve this using a JS snippet (which works, I logged it in output window using write line activity).
Post this, I’m using foreach activity to iterate and open all links that was got from JS snippet, which also works.
However, when I try Get Text activity inside the webpage opened using URL from foreach, it gives the error that Cannot communicate with the browser, please check the UiPath extension.
Note: I’ve used Navigate To activity inside Attach Browser activity, for the URL obtained using foreach

Extension Version: 9.0.6821
Chrome Version: 75.0.xxx

Please advise.

Regards,
Deepak Naidu

Hi @deepak.naidu

Have you tried updating all activity packages to their latest versions? (especially the UiAutomation and System ones)

It would help if you could reproduce the issue on a public website and share the entire .zip of the project. Just the part that doesn’t work, not the entire project :slight_smile:

1 Like

Hello