Install Error 2711 with MSI

I have downloaded the UiPathStudio.msi v20.4.3 and am following the command line switches on this side. I am running the installer as an admin on a Windows 10 machine.

For some reason some of the command line switches are not working.

If I run: UiPathStudio.msi ADDLOCAL=DesktopFeature,Robot (Runs the installer and can install just fine)

This works just fine in installing robot. But if I want to specify say

UiPathStudio.msi ADDLOCAL=DesktopFeature,Robot,RegisterUserModeService,UseRobotTray (Error upon installer starting up) or add any other switch after Robot I get this error

image

“The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2711”

I have re-downloaded the package and still get this error. For some reason those switches are not working. Has anyone else ran into this issue? Any help is appreciated.

Hello @tto!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly
Forum_Staff

Hi @tto,
Please read this documentation carefully. You are using this arguments:

Documentation says:

RegisterUserModeService - Installs the User Mode Robot. Can only be used with the Robot and the DesktopFeature arguments.
UseAgentDesktop - Installs Agent Desktop . Can only be used with the Robot and the DesktopFeature arguments.
UseRobotTray - Installs the Robot Tray . Can only be used with the Robot and the DesktopFeature arguments.

The key sentence is Can ONLY be used with
So you are trying to combine functions which can’t exist with other like RegisterUserModeService with UseRobotTray etc.

Hi Pablito,

I’ve tested this as well with just single switches alongside robot. For example
DesktopFeature,Robot,RegisterUserModeService
and still get the error.

Per the documentation and example on the site these switches should be be able to string together as long as the DesktopFeature,Robot string is indicated, but that is not the case. I’m wondering if anyone else has encountered this.

I’m back with small info from our devs. You linked old version of documentation for 19.x version of Studio:

RegisterUserModeService parameter is no longer supported in 20.4+.
If user wishes to install usermode, just clean install is needed and without RegisterService parameter.
But a clean install has to be done, cannot be moved via command line interface from servicemode to usermode, it’s currently a known limitation.