Error while installing UiPath Studio setup 19.10.1

I am getting an error while installing UiPath Studio.
The error message is:
“Service ‘UiPath Robot’ (UiRobotSvc) failed to start. Verify that you have sufficient system previliges to start system services.”

This is my personal system and I have admin privileges on this system.
Please advice.

hi @juelee

reinstall the uipath studio

thanks
ashwin.S

I deleted and downloaded studio setup again. Still getting the same error.

hi @megha12

try to change t he title as sha1*

thanks
ashwin s

Hi
Welcome to uipath community

Kindly have a view on this thread

Cheers @juelee

1 Like

Hi @Palaniyappan,

I went through the answer however could not understand the procedure mentioned in the Link provided in one of the answer. Can you please advice.

Thanks

Right click on the MSI package and run as administrator, I would expect it to prompt you but maybe UAC is disabled or something.

Alternative, use the EXE installer or provide the command line arguments to not register the robot as a service depending on your needs. (ADDLOCAL argument)

The referenced thread is advising of the same thing, but doing it through the command prompt.

If Studio/Robot was installed, can also open your Control Panel > Services and try starting the UI Robot service from there.

@codemonkee the option to run as administrator is not available for the MSI format. I downloaded the setup from an email and it got downloaded in MSI format. The trial version requires work emailand not gmail address so I cannot download Studio from this site.

Also, as the Studio is not yet installed, it is not available under Control Panel.

@codemonkee I tried to install using Command line parameters as mentioned in the article, however I am getting the same error.

Please advice

Try running the msi file as administrator. You can use command prompt to do this.

  • Run command prompt as administrator.
  • Provide the following command in the command prompt window started as administrator.
    msiexec /a "full path to the msi file"

If this does not work, try the below steps and install again.

  1. Navigate to Group Policy Object Editor > Local Computer Policy .
  2. In the console tree, navigate to Computer Configuration > Windows Settings > Security Settings > Local Policies > User Rights Assignment .
  3. In the details pane, double-click Log on as a service .
  4. Click Add User or Group and add the account to the list of accounts that have the Log on as a service right.
1 Like

Hi @KannanSuresh, I tried both the methods mentioned by you.

  • For the first method, the UiPath studio folder got installed however the application is not available.

  • For the second method, I added my user name under list of accounts and restarted the system. However, error message is still displayed while installing UiPath Studio.

Can you please suggest what should be done?

Can you try with Enterprise Version?

For downloading Enterprise Version, UiPath now requests for work email address and does not allow gmail ID. So I am unable to download enterprise version from the website.

Hello @juelee,

Thank you for asking.

please try to install it using admin privilidges.

you can achieve this by doing this

Regards,


Don’t forget to like us :heartpulse:
Happy Automation! :sunglasses:

You should be able to download it from https://platform.uipath.com/
Once logged in, go to the resource center to download enterprise version.

I had downloaded this enterprise version from the resource center and it gives error while installing. The setup is in “.msi” format.

1 Like

Being an enterprise edition feel free to contact our uipath technical team On this

Cheers @juelee

Hi @Palaniyappan, I tried raising a ticket in Technical Support however they mentioned they are not accepting cases where gmail domain is used. I have an official email address but I cannot use it for installing UiPath or any 3rd party work.
Can you please suggest any alternative method?

@juelee - Any updates on this issue ??

There was some issue with Admin rights on my system. I installed new version of Windows.