Issue with UiPath Studio v20.4.3


I’ve just registered to download and install UiPath Studio/StudioX Trial version.
I’ve received an email with some links, one for download the product and others for documentations.

Once downloaded the product (“UiPathStudio.msi”), I’ve tried to install it but:

  • Can not install the service “UiPath Robot” (UiRobotSvc). Check you have sufficient privileges…
  • [Pressed “Ignore”].
  • A new message box: “Service ‘UiPath Robot’ could not be configured. This could be a problem with the package or your permissions. Verify that you have sufficient privileges…”.

I’m actually local administrator in my machine.

I’ve followed a post saying to remove “ProgramData” and “AppData” folders, but it still breaks.

What can I do?

Thanks in advance.

Hi @agarcia.martin

Have you tried:

  • running the installer as administrator
  • checking if there isn’t some software that would interfere with the installer
1 Like


The “MSI” package can not be launched as Administrator; no option in right-click menu.
Also tryed with: “msiexec /a …” but nothing happens.

And no other installation in progress at the same time.

Maybe “antivirus”, Windows Defender or something like that?
May also be a digital certificate problem?


BTW… Which “privileges” need the installer?
Maybe I could check’em with our systems department…

One more thing…

We have detected that I’m using a “windows network account”, corporate one, instead of a “local-computer account”. May be this account-profile should be the problem?

Due to corporate policies, my profile account is NOT related with “Remote Desktop Users” group policy, and won’t be.

Hi, again.

If found a combination of options to launch UiPathStudio.msi installation:

"%HOMEPATH%\Downloads\UiPath Studio\UiPathStudio.msi" /L*vx "%HOMEPATH%\Downloads\UiPath Studio\UiPathStudio.Install.log" ADDLOCAL=DesktopFeature,Studio,Robot,RegisterService,Packages,ChromeExtension,JavaScriptAddOn APPLICATIONFOLDER="%ProgramFiles(x86)%\UiPath\Studio\" CHROME_INSTALL_TYPE=STORE CODE=<license_code>

from here:

Please, find attached the resulting log file:

UiPath (1.6 MB)

Take special attention to line for timestamp: “[09:59:08:112]: Executing op: ServiceInstall” and around.

Can you please help me ASAP?


Finally, we have managed to install UiPath.
We’ve discovered that there was a problem with the “UiPath Robot” service entry. Due to a previous (long time ago) installation, there was still an entry in the “Services” list that the installer could not remove/edit, so apparently that was whtt was throwing the error.

What we have done is to register that key (with a *.reg file from other installation) and launch the installer again. It works!

May be, your installation executable should detect, and remove, old entries in the services (o whatever) branch in the Windows Registry.

Hope this can help.


Thanks for your feedback, a note was taken :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.