SCCM command line for UIPathStudio.msi 22.4 is not working

Your MSI installer fro UIPathStudio.msi version 22.4.4 is not working when being installed silently via SCCM through an Application Package.

This should be relatively easy as SCCM should just pickup from MSI package but its not.

What weird is it worked when being installed for the first time using CMD with this command “UIPathStudio.msi /q” so I was confident that this would be successful in SCCM Application Package. Turns out its not. There’s that generic and hideous 1603 error. Happens on multiple machines I tested.

Even installing the application manually afterwards, it gives different results. Sometimes succeeding, sometimes not. Which makes this case more confusing.

I need to be able to package this in SCCM as an application and that it should be silent as this is for our users in our organization. There seem to be MSI engineering issues with the app.

We can’t afford to have this manually installed through our users as they are many!

I find this article of yours with no help at all: Common Installation Errors.

In have exhausted a lot of google searches and I cannot still make it working.

Run below command for SCCM Packaging:

msiexec /i "UiPathStudio.msi" /q ADDLOCAL=DesktopFeature,Studio,Robot,RegisterService,Packages,ChromeExtension,EdgeExtension,ExcelAddin /l*vx "c:\temp\UiPathInstallLog.txt"

1 Like

Unfortunately, this didn’t work. I tried this in CMD and didn’t work. Any other idea? Could this be an MSI engineering issue? As the installer is not behaving properly.

During testing, I have installed this successfully using /q parameter in the MSI. I then uninstalled then tried in App Package through software center as I am confident it would get through the same behavior as my testing but it didn’t.

May I know also if there’s other files that are not deleted when uninstalling the app and that they need to be deleted first?

Anyhow, this MSI installer is faulty in my opinion as it gives confusing errors evertyime.

1 Like

Check this information: Modify or Uninstall Studio

1 Like

Still the main issue lingers. This MSI is proving problematic as it won’t get installed via SCCM as it keeps throwing vague 1603 error. Logs has no help at all. Unless the MSI gets fixed, this will be challenging to be installed for our users.

Provide us with the install log to see the cause of the error.

Do you have an email I can send it to? As it is not allowing me here to upload the log file as it says I am only a new member.

Upload to and share the link.

Encountered error:

Telemetry.DesktopMsiInstaller.Error - Sent:False, Event:
{"Data":{"Message":"System.ArgumentNullException: Value cannot be null.\r\nParameter name: path1\r\n   at System.IO.Path.Combine(String path1, String path2)\r\n   at System.IO.Abstractions.PathWrapper.Combine(String path1, String path2)\r\n   at UiPath.Studio.Setup.Domain.Configuration.FilesConfiguration.ConfigFilesProvider.GetUiPathConfigPath()\r\n   at UiPath.Studio.Setup.InstallationTasks.SetProperties.DetectRelatedProductsTask.InitTelemetryForExistingInstalls(ITelemetryModel telemetryModel, String applicationFolder, String productVersion, Boolean isPerUser, Boolean requiresSessionInitialization)\r\n   at UiPath.Studio.Setup.InstallationTasks.SetProperties.DetectRelatedProductsTask.ExecuteTask()\r\n   at UiPath.Studio.Setup.InstallationTasks.InstallationTaskBase.Execute()","CustomErrorCode":null},"InstallationId":null,"Name":"DesktopMsiInstaller.Error","Container":"RobotTelemetryContainer"}

Possible cause: Proxy is blocking your connection to Telemetry endpoint. Installer checks, can’t reach telemetry endpoint, returns null value causing MSI to fail.

Try these approaches:

  • Remove all the data from %TEMP% folder

  • Try the below commands:

msiexec /i "UiPathStudio.msi" /q ADDLOCAL=DesktopFeature,Studio,Robot,Packages,RegisterService,ChromeExtension,EdgeExtension,ExcelAddin TELEMETRY_ENABLED=1 /l*vx "c:\temp\UiPathInstallLog.txt"


msiexec /i "UiPathStudio.msi" /q ADDLOCAL=DesktopFeature,Studio,Robot,RegisterService,Packages,ChromeExtension,EdgeExtension,ExcelAddin TELEMETRY_ENABLED=0 /l*vx "c:\temp\UiPathInstallLog.txt" 

Let us know if this helped.

Unfortunately, same issue when I tried the two commands.
UiPathInstallLog.txt (227.0 KB)

Now you have a different error message:

Telemetry.DesktopMsiInstaller.End - Sent:False, Event:
{"Data":{"Message":"System.Exception: Cannot find DisplayVersion in Registry nor from the installed UiRobot.exe.\r\n   at UiPath.Studio.Setup.Domain.Configuration.Versioning.StudioVersionProvider.GetDisplayVersionByProductCode(String productCode)\r\n   at UiPath.Setup.Shared.Configuration.Versioning.VersionProvider.get_InstalledVersionInfo()\r\n   at UiPath.Studio.Setup.InstallationTasks.SetProperties.InitPropertiesUpgradeTask.ExecuteTask()\r\n   at UiPath.Studio.Setup.InstallationTasks.InstallationCriticalTask.Execute()","CustomErrorCode":null,"Result":"Failure","Version":null},"InstallationId":null,"Name":"DesktopMsiInstaller.End","Container":"RobotTelemetryContainer"}
MSI (s) (00!14) [13:42:03:192]: Closing MSIHANDLE (93) of type 790531 for thread 2580
InitPropertiesUpgradeTask failed with:
System.Exception: Cannot find DisplayVersion in Registry nor from the installed UiRobot.exe.
   at UiPath.Studio.Setup.Domain.Configuration.Versioning.StudioVersionProvider.GetDisplayVersionByProductCode(String productCode)
   at UiPath.Setup.Shared.Configuration.Versioning.VersionProvider.get_InstalledVersionInfo()
   at UiPath.Studio.Setup.InstallationTasks.SetProperties.InitPropertiesUpgradeTask.ExecuteTask()
   at UiPath.Studio.Setup.InstallationTasks.InstallationCriticalTask.Execute()

It looks like the previous uninstall didn’t fully clean the previous version. You can check the uninstall log - it can be found in the %TEMP% folder, with the format MSI*****.log from the uninstall time.

After checking the uninstall logs, perform a machine restart and retry the

msiexec /i "UiPathStudio.msi" /q ADDLOCAL=DesktopFeature,Studio,Robot,RegisterService,Packages,ChromeExtension,EdgeExtension,ExcelAddin TELEMETRY_ENABLED=0 /l*vx "c:\temp\UiPathInstallLog.txt"


Seem errors are gone but still unbale to install for some reason its not installing. Logs shows no error and is very short.
UiPathInstallLog.txt (4.9 KB)


Do we have any luck on this?

We are also trying to install UiPath on Citizen Developer machines via SCCM silent install. We can’t get this to work and have been working with UiPath support on the issue for 2 months. Any recommendations or solutions you find would be very useful to us as well.

(post deleted by author)

I tried everything in this post to get the community edition installed on over 40 machines. The MSI is simply not working from within SCCM, even on a freshly imaged machine. We would love to introduce 40+ students to this product, but we won’t be able to if we cannot automate deployments of your software!

We are not supporting SCCM. In this case, stick to what we are supporting: Command Line Parameters


For anyone who will find this forum and may be stuck on the same way I am stuck, I have raised a call to Microsoft and we have worked on this for hours without success. Microsoft then reviewed the msi and found out that the msi is not supporting system-based installation but only user-based installation. Meaning, any user that will install this will need to install it themselves and given that they have admin access!! In which in our org, is not the case since we don’t give our end-users admin access (for obvious reason). Hence, we can safely say that this MSI is not suitable for SCCM packaging. We, as admins (with the help of Service Desk), would need to install it to their machines individually… we have 20+ users I think that will be needing this app and more to come in the future… Not sure how many on you guys… May the odds be on your favor :smiley:

1 Like

Hi @timothy.martinez,
As @marian.platonov our main directions were not strictly routed towards the SCCM. However, it doesn’t mean we are not interested in this kind of solution. We are listening to our users and we are really glad that you gave us this feedback. What is more important, we learned the lesson, and in the upcoming release, we pushed some features and changes that should fix the problem with the installation through SCCM. You can test it even now as this is a part of the Community Preview channel release.