How to get element of web dropdown navigations

uiautomation

#1

Hi!

Is there way to get uiPath to trigger navigation dropdowns. When I click a navigation element where i get dropdown, it hides when it loses focus and i cannot get the childs of that element. So it is somehow possible open dropdown menu and select element there without losing focus from the menu. I tried pause recording and get it to show the drop down but it loses focus when the recording starts. I have used firefox to do that. Thanks for all the help.


How to click dropdown
Finding Web Menu Dropdown child items
#2

Use F2 key to pause the indication for 3 seconds then you will be able to select the child element as well.

Regards…!!


#3

I didn’t get it working that way :frowning: It lost focus in the meanwhile and didn’t select right element.


#4

Instead of recording use simple click activity and indicate the element by using F2 then hover the dropdown and wait then select and still if you will not be able then have you installed? Uipath plugin extention for it? Use IE for better elements identification.

Or you can use “Hover Activity” as well.

Regards…!!


#5

Does IE also have some plugin for UiPath? Still trying different methods and the dropdown element always hides when UiPath is on “record” or “select element” mode. :confused: Really annoying.


#6

Hey @jmati

No Needs…!!

with F2 it works or just share a link

Regards…!!
Aksh


#7

Nope F2 doen’t work. It hovers to the dropdown but it doesn’t hover down from the dropdown to right element i have tried to get right element, it has the right text on the selector but still cannot find the right element. "Message: Cannot find the UI element corresponding to this selector:“
at UiPath.UiNodeClass.FindFirst(UiFindScope scope, String nodeID)
at UiPath.Core.UiElement.FindFirst(FindScope scope, Selector selector)
— End of inner exception stack trace —
at UiPath.Core.Activities.TaskAsyncCodeActivity`1.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)”


#8

Omg i was talking about to use it in code to select but at the time of recording use F2 To pause the indicator and manually hover it and make the pointer on that link and wait after 3 second the indicator will again show automatically then click it.

for more things please first go through with training materials.

Regards…!!
Aksh


#9

I have done that i have stopped the recording/selection with F2 and tried to select right element but when recording starts (after the 3 seconds) the element hides. Yes. i have looked through material. Maybe the site is just bad.

Hmm… Is there way to tell UiPath move down cursor this much and click?
Thaanks anyway.


#10

I’m assuming this is a hoverable dropdown, depending on the web sites settings it probably goes inactive before he can click the appearing link with uipath.

I tried it out and easiest way was to click on the dropdown link/button with UiExplorer and check it’s child elements, there should be all the menu items that dropdown has. From there just click the item you wish to click and copy the selector to your Click activity.

In the workflow select hover activity and select the dropdown menu with that and then click activity with correct item selector after that.

I noticed that the item you want to click is a link so you might also be able to just navigate there with the Navigate To activity.

Below is a working example.

Main.xaml (7.7 KB)


#11

Ok soon will upload a sample demo workflow for you. :slight_smile:

Regards…!!
Aksh


#12

Wow it works! Thanks a million!
Now i can continue my work. Thank you so much!


#13

I have a same problem when I use hover and click activity It see child dropdown but it not click


#14

Hey @aksh1yadav

For me this works most of the times too.But sometimes when i have to navigate to the third or fourth drop down it doesn’t detect(during recording). When i use the click activity it says parameter not valid(or something along that lines, don’t remember the exact error). I then restart or probably try again after a while it detects .Any idea why? Faced this a couple of times but cant figure out why.


#15

Hey @Nivetha123

Screenshot of that error will be much better the error description to reach out at a particular assumption :slight_smile:

Regards…!!
Aksh


#16

Hi Aksh

I tried Uiexplorer on chrome and press F2.
the hover is shown for 3s. however, after 3s the hover is gone as well.
I tried it again by using IE.
i can able to select the child link.
Is there something wrong with chome? If I want to select the child do I have to do all the workflow in IE? or use only on IE?
Now I doing all the workflow on chrome. Do i need to change it to IE?
Thanks
Hung