Selector not found only in orchestrator

Hello everyone,

I’ve just connected my first robot to the orchestrator which worked fine but when I run it from the orchestrator I always get a ‘selector not found’ error. This does not happen when I run the robot in the UiPath studio. It executes all excel activities when ran from the orchestrator but fails with opening the IE browser.
Any suggestions why this happens and how I could fix it?

Many thanks in advance!

Hi @juka
Can you post the error message.


Hi @juka,

If you are running the bot in an unattended mode, then while using activities like Click, Type into etc. can give the following error.

Please check the simulate click property and try the same.
Please let us know if it works.


This ist the error message I get:

  • Info: Cannot find the UI element corresponding to this selector:

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
UiPath.Core.SelectorNotFoundException: Cannot find the UI element corresponding to this selector: ----> System.Runtime.InteropServices.COMException: Cannot find the UI element corresponding to this selector:
at UiPath.UiNodeClass.FindFirst(UiFindScope scope, String nodeID)
at UiPath.Core.UiElement.FindFirst(FindScope scope, Selector selector)
— End of inner ExceptionDetail stack trace —
at System.Activities.Statements.Throw.Execute(CodeActivityContext context)
at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.ActivityInstance.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

Hi @ronak_94,

thanks for your help. Unfortunately this doesn’t work either. It already fails before the browser is opened.

Best regards

Hi @juka

Can you identify the selector for that activity where its throwing this error and compare it by using ui explorer by indicating element on screen.


What is exactly the activity that is throwing the error? And there is a change that something is failing and the browser is not really open on the moment the activity is being performed?

Hi @juka
if the browser is not open when performing a ui activity it throws error.
use some delay until the browser is opend for the activity throwing error.


Hi @joaoresi,

the first thing it should do is to open the browser but it seems like it doesn’t even try to do that and then it fails with the first activity that should be executed on the UI in the browser which is a ‘set input’. I’ve ran the process more than 60 times in the studio and never had a problem with that.

Hi @balu,
I tried that but unfortunately it doesn’t work either. Seems like it doesn’t try to open the browser at all. In the studio it works perfectly fine.

did you try this other browsers ? chrome,moziall ?

Hi @juka,

So the problem would be with opening the browser. How are you opening it?

Hi @allurai_india,
no, I haven’t but I would prefer using IE as changing to another browser would require a lot of work to change the whole process.

Hi @joaoresi,
yes, I use the open browser activity.

As you say that Excel activities all work and then it has problems with browser activities, probably it is running in a session on the machine with no DCOM permissions. Check if you have run as batch job permitions on the user you are running.
Follow this and try again :slight_smile:

1 Like

Hi @joaoresi,
this might be the cause. Unfortunately I cannot change it as I have no admin rights but I will try to get it done somehow.
Many thanks.