Get outlook mail message activity, shows the specified folder does not exist while reading the inbox from outlook

Can anyone help me to resolve this issue as i am progressing RPA developer foundation course and while doing the first automation , i faced this error, does anyone help me to resolve this error?

Hi @Gokula_Krishnan_S, do you have Outlook configured in the machine you are running the bot? If so, do you have the property ‘Account’ empty for ‘Get Outlook Mail Messages’ activity?

Hey

Welcome to the UiPath Community Forums! :partying_face:

Can you share the properties pane also?

Cheers

Steve

Hi Vamshi

Thank you quick assistance. Yes outlook has configured , and yes i kept , account empty in the properties panel

Hi Steve,

Thank you quick assistance. Please find the attached for your reference

Hello again

Can you share the filter query?

Try and get it reading emails first then add new factors/settings slowly to find the problem.

Cheers

Steve

Hi steve

Please find the filter query

It’s all looking pretty okay/safe :thinking: - is the folder “Inbox” still intact?

Hi Steve,

This issue seems to be faced by everyone while performing this outlook activity, just now watched in community ( Get outlook mail messages : The specified folder does not exist - Help - UiPath Community Forum, i tried resolution like uninstall and reinstalling outlook, running outlook as admin and not giving account name in properties panel and giving the folder name as case sensitive. still getting the same error.

Yeah the behaviour is a bit strange and is topical :sweat_smile:

Try this:

  • Increase the Timeout interval for the mail related activities or use a Kill Process activity to close the Outlook processes before using the mail activities - this allows for a clean start for the Robot.
  • Update the Mail Activity packages to latest version.

Check this post:

Hello Gokula
There is one more thing that you may need to consider. If you are trying to complete the activity by specifying the inbox path of your Outlook web app then it will not work. The activity is specifically for Outlook desktop app. So login to your Outlook on desktop and then run the workflow. It should work. I was also facing the same issue. Then I tried with Outlook desktop and it worked :+1: