Get outlook mail messages - the specified folder does not exist

Hi,

I have a process which uses a Get Outlook Mail Message activity to retrieve an email, get the attachments from that email and then process those attachments.

The process runs, end to end, with no issues, providing the desired end result on one machine, but when I try and run it on a different machine - the one it needs to run on - I get an error of:
Get Outlook Mail Messages: The specified folder does not exist

I have checked across both machines and I am running the same version of Outlook and the same version of UiPath. The settings across both machines are the same as far as I can see.

I have tried every possible answer I can find on the forums and am hoping someone may have another idea.

Thanks

Hi @rebekah.batley

You can check Outlook Mail Folder and Get Outlook Mail Message Activity

Regards
Gokul

In addition to @Gokul001 response, also try increasing timeout of your UI Activities if you are using along with get outlook mail message activity as due to heavy size of group mailbox, this issue may occur sometimes.

Thanks for the advice so far,

I have a huge Timeout on the activity, it hasn’t had any impact I’m afraid

I have tried with my required Account information in the Account field and with Account empty, no effect, I have also tried with “Inbox”.ToString, as well as without “Inbox” in the MailFolder field.

Hi @rebekah.batley ,

This error occurred when Account name is not correct.

Please make sure it is used as it is, as the account name is case sensitive.

Ex - test@uipath.com - Wrong
Ex- Test@uipath.com - Correct

Hi @ermanoj3101

Thank you for this suggestion, the Account name is stored in an Asset (this is part of how we work/our best practices as an automations team) I have however tried hardcoding the email account name to test your advice and I still get the same error

Can you please share the screenshot of your outlook property panel ?

Outlook properties

I have attached a screenshot as requested.

I don’t think the issue lies within my process as the process does work - including the outlook parts - it just only runs on the computer I use to build and develop on, when I move it over to our test or live machines it won’t run and I get the specified folder error.

Hi @rebekah.batley

Can you try to remove Account and check it?

R2gards
Gokul

Hi @Gokul001

Same error

Thanks
Bex

Hi,

Did you try to put another mail folder to see if it is an issue with the “Inbox” folder? Do you know if the Windows language is exactly the same in both machines?

And as @ermanoj3101 mentioned, account names can be different from one machine to another, double check in the properties if it is exactly the same account name in both machines (with capital letters etc) :slight_smile:

Best regards,

Hi @melanie

Thanks for your suggestions, I have tried multiple other folders, same error. I have checked the Windows language to the best of my knowledge and everything looks to be exactly the same across both machines.

The account is the same across both machines

Thanks
Bex

Hi,

Ok, it’s a very strange behavior. Did you try other Outlook activities, like a Send Outlook message? If other activities are not working too, it can be an issue with Outlook itself (with .pst file corrupted).

Good luck

Hi @rebekah.batley ,

This looks fine.

Why i was saying to check Account name as I had faced same issue in past and it was corrected by using same Account name as configured in email.

Try to copy it from outlook once, if already tried please ignore.

Refer below screenshot.

Try to use the email as it is in this location. As @ermanoj3101 mentioned, it is case sensitive sometimes.

image

OR from Account Settings

image