[ERROR]: Get Outlook Mail Messages: The specified folder does not exist

Hi, I am trying to implement a simple automation using outlook, but getting the error: Get Outlook Mail Messages: The specified folder does not exist.
Can someone please help?
Thanks in advance!

1 Like

Do you have office 365 - outlook installed in your system

1 Like

→ Double-check the folder name you have provided in the “Get Outlook Mail Messages” activity. Ensure that you have entered the correct folder name, and there are no typos or extra spaces in the folder name.
→ Make sure that the account used by the robot has the necessary permissions to access the specified folder in Outlook. Sometimes, the robot account might not have access to certain folders, causing this error.
→ Instead of specifying a custom folder, try using one of the default folders, such as “Inbox” or “Sent Items,” in the “Get Outlook Mail Messages” activity. If the default folder works, it indicates that the issue might be with the custom folder name or access permissions.
->Ensure that the Outlook application is configured properly with the correct email account, and the mailbox is accessible without any issues.
→ If you are trying to access a subfolder within a main folder, ensure that you provide the correct folder path in the activity. For example, if you have a folder named “Project” under “Inbox,” the folder path should be specified as “Inbox\Project.”
->Sometimes, issues can be resolved by simply restarting both Outlook and UiPath Studio or the robot service.
->Try accessing a different folder within the Outlook mailbox to see if the issue is specific to that particular folder or a more general problem.

2 Likes

Yes, I do have the Outlook app in the system

Try mentioning the account in the properties panel

Outlook_Invoice1.zip (74.3 KB)
Hey @shami you can try referring this

Hope it helps you Out

Hi @shami

You won’t be able to use Get Outlook Mail messages activity if you don’t have Outlook installed in your machine.
You can use microsoft activities. Download UiPath.MicrosoftOffice365.Activities.

Hope you understand
Regards,

@Parvathy she has outlook installed in their system

Hi @shami

I think the folder in your outlook is not there in your outlook account. Do check the Inbox folder is in your account.

Hope it helps!!

Hi @shami

Once try to delete the activity and reassign it.

I hope it works!!

Today i had this issue, the solution for me was simpler than i thought.
i noticed that my outlook app (2013) was displaying the words : Inbox , sent items etc on my native language, although the app display was in english, eg options, home, file, save etc.
It appears that the web app was setted by default on my native language and that was confusing the app as well

i changed the language from browser and affected the app as well.

  1. https://outlook.live.com/
  2. From top panel Home ; View . Help choose View
  3. From drop down choose View Settings
  4. General
  5. Language English
    error-get-outlook-mail-messages-the-specified-folder-does-not-exist

Hello @shami
Try this :

  1. update the Packages : Go to DESIGN → Manages Packages → click on the bleu icons if the packages are not updated → final result will be like what you see in the screen

2.be careful when declaring variable, it must be like this :

  1. make sur to place for example the UiPath ACME in one folder under the principal folder ‘Boite de réception’ in my case (maybe : inbox in your case)
    image
    and then name the MailFolder field with “Boite de réception\UiPath” (your case : “Inbox\UiPath”)
    image
    You can chose the option OnlyUnreadMessages but be careful because if the mails are readed in Outlook, UiPath will not find them. :slight_smile: (You can disable this option for test)
    last remark, do not enter your email in the Account field if you have only one account in Outlook

  2. Save your changes and run the process

  3. Have Fun :wink:

r_bettach

Hi

I’d like to give one advice.
When you use to a folder inside Inbox and this folder contains a space between words for example: Inbox\My new folder
You have to use the name of folder in the container Outlook in this way: Inbox\My%new%folder
I also had a problem with this and now it’s working.

1 Like


The same problem here…I’ve tried everything to fix but failed.

image
esse é o outlook que tenho instalado ou uso tambem office 365 da faculdade

Have you managed to get it work.

not…I have tried many things…but still the same problem…and I cant foward with certificate