Feed the values into table in the desktop application

Hi Everyone, Can you please help me to insert the values in to the Table in one of the Desktop application. Its not working for me to set the text for the rows in the Table.

Please find the below table structure for the reference.

@bharathbanchalli
How are your values stored that you want to feed into the desk top application table?

It’s a variable data which has been fetched from excel in text format

@bharathbanchalli
You would Read Range Excel to Data Table, then For Each Row in Data Table use Type into activity of Data Table CurrentRow.Item(“column name”).ToString into each field of data table.

regards

Type into activity is not working

Hello Everyone,

I can able to read the data from the above table, but it’s not allowing me to set the values

Used the below options

  1. C V type into
  2. Type into
    I can’t able to get the back end I’d of the table

Please help

How are you setting the values from the data table?
What exactly is happening when you try CV Type Into or Type Into activities?
What do you mean by "I can’t able to get the back end I’d of the table?

Can you send images of your process and the application please also?

@michael.zura

Please find the below screenshot of the applications.

Need to feed the above table by excel values.

I tried the below activities which didn’t worked:

  1. Set Text activities.
  2. Type into activities
  3. CV Type into activities

Does it give you any errors? You can select the application with a Use Browser/Application activity? It does not work, but how or what happens?

Yes i have tried that one as well using use application, however its allowing to set the text in the table. Its taking whole application into picture and not allowing me to select the particular cel in the table.

Please find the below screenshot

@michael.zura Any suggestions please

@bharathbanchalli
Have you tried changing the UI Framework when selecting or using Image Region selector?

Looking at your image, normally you would click into a cell to enter data? Is it auto saved or is there another click required?

Regards

Yes your correct need to enter the details in the table and click on the submit.

Yes i tried the option of UI framework as well

This is a Powerbuilder Application, does UiPath supports this?

Seems others have faced similar troubles.

Not sure what version but maybe check docs for your version of power builder and see about UI Automation such as:
https://docs.appeon.com/pb2019r3/whats_new/UI_accessibility_support.html

Dear all,

Please help me with the possibility it’s very important thing to crack for me