How to insert data into a Table inside a desktop Application

I have a desktop based application where there is a table in the below format.

Column1 | Column2 | Column3
_________ |__________|__________

I have the respective data for these columns in data table. First row is available for entry and once all the data is filled in all the three columns for that row, next row appears.

What I have tried -

  1. Tried of locate the first row for entering the data and used tab keys to move to nect columns.
  2. Have used for each loop and increment the counter for next values.

Problem Statement -
I’m able to select and enter the data row wise (by using the CV Type Into / CV Dropdown Select). But as there are more than one values, I can’t just select the scope for each row (as it will depend on the input data).

Is there any way I can insert the data for a particular column and increment the rows based on the input data so that It can insert data in row1, row2… row(n) for Column1 and similarly for the other columns.

Any suggestions on this would be really helpful.


Can you show how it looks in the application

basically you can get each column value also if you need

just use for each row activity once for each column…and in loop each time use each column separately

and in application use the idx value on selector to change the value in same column but different rows…for index in for loop properties you will have an index proeprty cna sue the same


Please find the table for your reference.

I wish to insert the data in this table. First row is available for inserting data and next row appears once the data is filled in first row.


Then use idx as said…the first row will have idx as 1 …second will have idx as 2 and so on


Thanks, Anil!

Will it be possible for you to share any example as in how I can use the index value on selector? just for my reference.


This is how it looks

index and requiredIndex are integers…adding 1 because index starts from 0


Thanks, Anil for the example.

Is this edit selector you did on TypeInto Activity? If yes can you pls share the version of your UiPath.UiAutomation.Activities package? As for me I’m not able to see any option for Edit Selector for TypeInto Activity.


This si how youc an edit selector…click on highlighted 3dots


Thank you so much Anil, this helped!


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.