Desktop has been disconnected while performing UI actions still persists

Hi @badita @loginerror and all, While running the robot from Orchestrator i am getting the following error: Desktop has been disconnected while performing UI actions.

If the session is kept open, it is able to perform the activities(Ui Interactions)
If the session is ended(RDP is closed or not open at all) it throws this error.

I have tried the resolution as UiPath does not work in Cloud but still facing the same issue.
Login to console is also set to “True”.

Please help,
Thanks in advance.

@jibanjyoti

May I know what type of Robot are you using ?

And also are you using Community or Enterprise Edition of Uipath studio ?

Hi @lakshman I tried with both development and unattended type robot. Yes, it’s an enterprise licenced Uipath studio.
Thanks,
Jiban

1 Like

@jibanjyoti

But Unattended BOTS it won’t happen. BOT only will login into the system and will perform actions once it done it will logoff from system automatically. And also Remote Desktop won’t be disconnected in between process running.

As you said it is licensed version please contact Uipath support team and they can help you better in this I guess.

1 Like

Hi
Kindly have a view on this thread
Hope this could help you

Cheers @jibanjyoti

@jibanjyoti: I am also facing the same issue May i know if your issue is resolved is please do let me know…!! it is very urgent…!! Please
I have tired resoltion in orchestrator too didn’t hell

Hi @jibanjyoti and @Pavani_Mahaveer

It may happen because of internet issues, or server disconnection or robot disconnection, another user signs in using RDP and Closed the session.

It is also advised to set LoginToConsole to False, by default it is set to False only but enable it and set it as False manually in the Robot Settings. For me, it worked on several occasions.

Hope it helps.

Warm Regards,
Ranjith Udayakumar