Desktop has been disconnected while performing UI actions- Ui error

I am getting this error -Desktop has been disconnected while performing UI actions when bot is running in unattended mode and when I am login to Remote Desktop and deploy it through Orchestrator manually than it getting executed without any issue.
Can anyone guide me what exactly the issue is why it is not running in unattended mode.
Is this version issue because my studio version is -2022(latest version) and Orchestrator version is - 2019.10.14

Thanks in advance

Can you confirm that you have UiPath Assistant installed on the Remote Machine and connected to Orchestrator with the same User/Robot the unattended License is connected to?

Thanks for reply. Yes it is connected with same license. And when I am inside the RM desktop and execute the process through UiPath Assistant than also it is executing the task as excepted

Can you please check in Orchestrator:

Tenant > Manage Access - Select Robot Account and go to Edit, Click Robot Settings and check “Session Settings”. Try to change them and rerun the process (especially the first one “Login to Console”)

Hey @Maqsood ,

Try to change the robot setting, enable to option Login To Console and try to run the process from orch.


Thanks for help. I will try and update

Thanks for Input. I will try

Hi @iamNairda & @Sanjit_Pal
I tried the both the suggestion but getting same error in unattended mode.

You can try adding the resolution like I have for an unattended robot:

Usually this step shouldn’t be necessary, but sometimes it helps. Please don’t just copy, but set it to the resolution you created the automation for.

Also if this doesn’t work, can you share the full error log from Orchestrator?

Hi Getting same error

Hi ,
Is this issue because my Orchestrator version(2019.10.14) is not same as Studio and UiPath Assistance(2021.4.6) ?

Hello @Maqsood

Refer to this thread that might help you.

Best Regard,

1 Like

Thanks for help but only my UI specific processes are not running and rest processes are running as required in unattended mode

@seanrockvz13 - Can you suggest some input on my issue.


This is important information.

Can you create a new process and downgrade ui automation package to same version as assistant on unattended machine or just so it is supported (you can read it in the package details). Just try it in a new process and not the current one.

Thanks for all your inputs @iamNairda @Sanjit_Pal @NutchanonSwnl
issue resolved

What did resolve your issue?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.