Desktop has been disconnected while performing UiAction when running Unattended from Orchhestrator


I keep getting disconnected when running a process from the orchestrator. I have seen other threads and tried following:

  1. Go to the location HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server
  2. Create or edit the DWORD value of KeepAliveEnable
  3. Set it to 1 .
  4. Save and quit

And also:

adding HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Terminal Server Client - RemoteDesktop_SuppressWhenMinimized and set it’s value to 2.

I have set a resolution for the robot on Orchestrator and also tried setting Loging To Console to both Yes and No and nothing worked for me.

Does anyone have any other solution.
Thank you

Hi @Andrija_Pejcic

you can this post as well,


Hello @Latika10011740

Thank you for the reply.
I have set it up in HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Terminal Server Client as well and still no luck.

I have also changed config file’s LoginToConsole to False

If anybody has this problem with the latest version, I have seen that in the past newer versions were getting disconnected so the solution besides mentioned the ones from above would be to move to the previous stable version (reference: ui automation - UiPath Error : Desktop has been disconnected while performing UI actions - Stack Overflow), and I have downgraded the studio from the latest beta 20.10.2 to the 20.4.3 version and it solved the issue.

Anyways, thank you for your help @Latika10011740

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.