Could not connect to UiPath Robot Service. Make sure the service is started!

robot
robotservice
p_notaproblem

#1

Hi! I’m trying to execute my first robot and I can’t and I’m getting the following error:

Could not connect to UiPath Robot Service. Make sure the service is started!

Do you know the meaning of this error?

Thanks


UiPath service doesn't start
Activitie "Send sms message"
Robot does not recognize published projects
#2

Hi Maru
This error is because,UIRobot service is not started.
you can start the service manually from Component Services.

Thanks
Udaykumar


#3

Go to Windows Services (type “services.msc” on startmenu) and start the service named “UiRobotSvc”.


Cannot connect to UiPath Service error
#4

Hi Muru,

First Try to start the robot service in C:\Program Files (x86)\UiPath Studio\UiRobot.exe

But the last version avable on uipath.com have this issue.I had a similar problem.

You need to use an older version, try the version 2016.1.6057 or versions prior to this.

Regards,


#5

Hi I try to follow the steps you mentioned but I couldn’t able start the “UiRobotSvc” bcz the start option is faded.,and same i try to do in task manager but its showing access denied .


#6

it works


#7

I am also faced same issue but it resolved now

Goto–>All Programs–>Services.msc–>it will open the all windows services -->start the uipathservices


#8

Hello, I have the same problem with version 2016.2.6274 .

In services.msc the run button is blurred. How can I solve it?


#9

Hi @bogdan_margarit,

I had this problem this week with the same UiPath version and once I have repaired UiPath with the installer, it started to work again.


#10

I tried to repair but it gave me an error when trying to start services. The error is that I don.t have enough rights to start services.


#11

Hi @bogdan_margarit,

This message occurs when you don’t have admin privileges in your Windows PC, so in this case I suggest you to ask for someone else who has those privileges.


#12

This will be because of hardening of the system


#13

Hi @Thiago : I am not able to find the UiRobotSvc in my services list. Any ideas why it is not appearing there ?


#14

Same issue,

same workflow was working well before 2 weeks


#15

Hi ,
How about running from directory
C:\Program Files (x86)\UiPath Platform\UiRobot.exe


#16

hello @ddpadil thank you for response, I tried the same no success ,

image

image


#17

@hkjobs1988,

Do you have admin access.
Could you try opening service from task manager and try to start the service from the there.


#18

@ddpadil, thank you for response was showing access denied when i tried it manually, as of now it is working ok after I started the system next morning :wink:


#19

I don’t have option to Start services. How do I start it?


#20

I also face these kinds of situations. But after restart my PC my problem get resolved.