UiPath service doesn't start

robot
robotservice

#1

Hi,

I had installed uipath in one of my windows machines. Initially it was working fine.

But now, the uipath robot service won’t come up and it doesn’t allow me to access the editor.

I have tried starting the robot service by accessing the uirobot.exe under windows>>program files(x86)>>uipath. But this doesn’t work.

Please help me with a solution.


#2

Hi @Ashok,

I had this problem in my machine too, it seems to be intermittent, but whenever it occurs try to restart the machine or restart the service using the Task Manager (Windows + R -> taskmgr -> Services Tab).

However, as mentioned here you could also do the following, please try to search the forum posts before posting something, so it would avoid duplicated threads from something that have already been discussed.


#3

Hi acaciomelo,

Thanks for writing.

This should have worked. But as mentioned in the post, the services for robot is faded out. For which, I am not able to start the service manually.

Please let me know if anybody has an idea on the approach for resolving it.


#4

What version are you using?


#6

Hi Ashok,

This is for Win 7 .

If you want to start UI Path Service then go to task manager and then click on Service Tab (3 rd tab) .

Then Look for Services at bottom right on the same Services Tab.

When u click on it, you need to enter admin password and then you will get a list of all the services.

You need to look for UI Robot Service and then right click on it and click option Start Service.

and Then save.

Then u need to run the UI Path project and it will work fine.

If you still have doubts please post few screen shots with detailed description.

Regards,

Prashant Singh


#7

@PRASHANT_SINGH I tried your suggestion mention above but Start tab in the manu is clickable , any suggestion.


#8

Can you paste the screenshot of properties?


#9

Hi ,

Follow the attachement.

Thanks and Regards,


#10

Hi @vvaidya ,below is the screenshot of properties same issue , on right click Start tab is not active , and in properties as well start option is disabled

image


#11

Assuming you have started the service/logged in as an admin, check if this can be of any help