Cannot connect to UiPath Service error

robot
robotservice

#1

Hi we are getting this error every day we have to restart computer many times to fix this,
please can anyone tell me how to fix it.
We have contacted uipath japan also as it is paid license but there is know response till now.

Regards
Nara
errorpic


#2
  1. are you starting the uipath studio service from services?
  2. do you have admin privileges to that computer?
  3. can you check if any antivirus is blocking?

#3

hi @vvaidya what is services??
1.we have front office license.
2.also we have admin privileges
3.Yes there can be some issue related to security as we have good security over here.[but when we used to test before entering the license we never had this issue we tested it for nearly 1 month]

Thanks
Nara


#4

Please go through this


#5

Thanks @vvaidya i will try it now

Regards
Nara


#6

Hey @Nara

It has been solved? or

well just wanna know? what is startup path has been setup for UiRobot service on your system? It should be Automatic(Delayed Start).

and one more thing it happens due to network domain changes as well. Support you are in a corp network domain and if you will change your other virtual network domain then also it asks to start the robot service.
Faced this with studio version 2016.2.*. Not checked with latest one but faced such issue in the past in above scenario even i also was admin their :slight_smile:

Regards…!!
Aksh .


#7

Thanx @aksh1yadav it is not solved yet but i will check your point and let you know.

Regards
Nara


#8

hi @aksh1yadav where will i find this property ??bec when i searched services.msc on search and then i searched it there was no uipath or uirobot services.

Regards
nara


#9

Hey @Nara

How you installed studio. at the time of installation you have done something with advanced option?

image

check in your C:\Program Files (x86)\UiPath Studio\ their Uirobot.exe exists? if so run it once.


#10

ohh i see,i think new team member did something wrong while installation.
i will check it thanks.

Regards
Nara


#11

Hi @aksh1yadav
the start function is disable i could not able to get started
can u suggest how to do it !
i am new to RPA and using the trail version

rpa


#12

Hi shiva,

Please try with the steps below:

  1. Go to Start > Run > and type regedit.
  2. Navigate to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
  3. With the control folder selected, right click in the pane on the right and select new DWORD Value
  4. Name the new DWORD: ServicesPipeTimeout
  5. Right-click ServicesPipeTimeout, and then click Modify
  6. Click Decimal, type ‘180000’, and then click OK
  7. Restart the computer
  8. Open command prompt in elevated privileges.
    9). Navigate to UiPath msi installer directory.
    10). Execute command "msiexec /i UiPathStudio.msi /qr"
    11). Please keep on check that the installer does not roll back.
  9. You should be able to start the service now.

From this post:


#13

Hi @ovi
thanks for ur support
but i am getting error
PFA


#14

Hmm, it seems like you don’t have permissions. Google says to right click on the folder -> Permissions… -> Advanced: change the owner or allow full control on your user group.


#15

To interact with windows service and other Registry changes you will need an admin right of that particular system :slight_smile:

Regards…!!
Aksh


#16

its working
@ovi & @aksh1yadav