Could not start UiRobotSvc manually!


#1

Whenever we have a system reboot, we get this message: ‘Could not connect to uiPath Robot Service, Make sure the service is started’.

Tried to start UiRobotSvc manually also from the task manager, we get message: ‘The service does not respond promptly to the start’.

Please help!


#2

hi,

I faced this problem too.
Only solution is to repair UiPath every time u get that error.
That’s why I never close UIPATH. I just lock my system. :stuck_out_tongue:


#3

Thank you for your response. Unfortunately, I work on a remote machine and system admin is not happy to reinstall every time there is a system reboot or restart ):


#4

Hello.

You can have that error for multiple reasons. For starters can you follow the steps in this article and see if that fixes the issue?
https://www.kepware.com/support/knowledge-base/default.asp?solution=/_ui/selfservice/pkb/PublicKnowledgeSolution/d?&id=50140000000RyQsCsY


RPA Developer - FoundationTraining
#5

Antivirus may also be a common issue.


#6

Yep that’s another one. Also make sure your user has the right to start UiPath Robot Service.


#7

Thanks for your response. We perform a program repair on UiPath and problem gone for now:slight_smile:. I will notify the system admin of your provided solution in the event of a system reboot. Thanks a lot!


Cannot connect to Uipath robot
#8

I think this is the problem I am having, but I do not know how to check/edit the user rights. Can you/anyone tell me how to see who has the right to start UiPath Robot Service and how to edit those rights?


#9

@JWhite Did you check the windows Services(Start menu -> type Services) to see if UiRobot svc is started?

In windows 10, to check user rights, go to Start menu -> type netplwiz. In User Accounts window select your user and click Properties. There you can choose the level of access for that particular user.


#10

@ovi I did try to start the UiPath Robot using Services.msc but i got the below error. Even when I went to netplwiz and gave admin access to myself I got the same error.

image


#11

@JWhite did you run Services as administrator?
Screenshot_43


#12

@ovi Unfortunately I did and it did not help.


#13
  • What version on Uipath do you have?
  • Are you running PC remotely?

#14

@Daemo I have uipath studio 16.2.62, and I am not running remotely.


#15

I will suggest you go to ‘program and feature’ to perform a repair on application. Otherwise, get the latest version 17; You wont have any service problem with that. I currently have both the 16 and 17 version running off my PC. :sunglasses:

Hope that helps