Automation has stopped working (broke)

The process in question worked normally, but in one step of the process it can no longer identify the field “advance” to the next step.

When I manually click Next, it continues the process normally.

But in another step of the process that has the advance button it stops working again.

How can I solve?

I’ve tried a few options without success.

Hello @pdcampagnini

Can you replace the title value with * and keep only aaname attribute. Validate it with UIexplorer and add to the click activity.

I think in your case its not throwing any error. it means its actioning. Maybe you can add some delay also.

First try it with debug mode in a slow run.

I tried to debug it slower, but I didn’t succeed either.

I changed the titles by * and the same error remains.

It appears error in the next step of the process, apparently it performs the function of clicking next, but the system does not identify the click and does not proceed to the next step.

The strange thing is that the rest of the process works normally with the clicks, I’m thinking that the problem is in this advance button.

What can I do about this situation?

@pdcampagnini If you are using the modern designer, can you use App/web recorder and record the click action for that particular step.

If not possible, Inspect that element using UiExplorer and check whether any values are changing in the selector. If yes replace all those values with *

I opened another process and just clicked on the advance button and compared it with the automation click.

I’ve noticed that the structure changes, but I don’t quite understand about it… I believe that’s why advancing automation isn’t working.

Any idea?



@pdcampagnini can you click on validate and check whether Rita a valid selector? If yes, can you click on the indicate in the Ui explorer and check whether it’s highlighting the button in the web page…

Also did you enable simulate click in the click activity ?if not try with that as well… Also add some delay before to this click activity

Replace those & encoded characters with * to wildcard them out then test. Also look at the other properties of the object and see if there are things that are more reliable than cls. In fact you can probably just remove cls - aaname should be unique.

It’s also possible the automation is just moving too quickly and the button isn’t ready to be clicked. In modern you can use the validation features of the click to make sure the expected result happens (that Novo Doc object appearing) and set it to retry until the expected result appears.

Good morning, I tried to make the suggested changes.
I removed the cls and the validation worked. But when you replace the & by *, it gave a validation error.

The strange thing is that it works in another process and in this flow it stopped working out of nowhere


I didn’t understand very well, I believe this is it?

I tested the selectors and they are valid

@pdcampagnini can you replace all the & starting values with *

like &gt, &amp

It would be like this?


wnd app=‘sagrcest.exe’ cls=‘TFFatu*’ title=‘Fatu2041 - Entradas de Nota Fiscal’ />
wnd cls=‘TPanel’ title=’ ’ />
wnd aaname=‘Avançar >>’ cls=‘TBitBtn’ title=‘A&vançar >>’ />

wnd app=‘sagrcest.exe’ cls=‘TFFatu*’ title=‘Fatu2041 - Entradas de Nota Fiscal’ />
wnd cls=‘TPanel’ title=’ ’ />
wnd aaname=‘Avançar *gt;gt;’ cls=‘TBitBtn’ title='Aamp;vançar *gt;*gt;’ />


can you try the below

<wnd app=‘sagrcest.exe’ cls=‘TFFatu*’ title=‘Fatu2041 - Entradas de Nota Fiscal’ />
<wnd cls=‘TPanel’ title=’ ’ />
<wnd aaname=‘Avançar*’ cls=‘TBitBtn’ title='vançar’ />

make sure syntax is proper and validate it .

Did not work

Did you get to see the two image comparisons I showed at the beginning of the forum?

The two boxes have the same nomenclature, but the colors are different (I feel silly talking like that), but I don’t know the correct term lol

You have to remove the ENTIRE & encoded value, not just the &.

For example, this…


Is the encoded form of greater than


So you replace &gt; with *

I don’t think it will be a problem here. Can you delete the click activity and try to record it using App/Web recorder and give a proper anchor during recording.

It should work. I think the language is not english here for the buttons. That’s why some unwanted characters are coming in the selectors.

I tested performing the web recording and it didn’t work.

Will I have to completely redo the entire process?

I’m just depressed because I don’t understand why the same activity works in one location and another stream doesn’t

The results of the recorder are no different than just doing the activities one-by-one.

I made the change just like our other friend suggested, I believe it was the same thing you suggested.

Did not work

Forget the recorder. It doesn’t do anything any different. Just focus on getting your selector(s) correct. You’ll find a strategy that works for this app.

I noticed this, when I put some recorder steps… the selector data is the same