Automation not working on another device

The automation worked and then stopped working on another device. The first thing that stopped working was a click function - I am hoping that if someone helps me solve this I will be able to apply that to the others.

I an trying to click a text box in a web (with the control button) so that I can replace the text with my variable. The selector is as follows:

I don’t know too much about wild cards but i tried to do one and it did not work. I have heard selctors with ID are not stable but do not know how to fix this. Any suggestions?

Thank you!

If you are able and have studio on both devices, get both selectors and compare them?

Indexes can vary on websites, so it is safer sometimes to not, Use UiExplorer to finetune your selector to accomodate.

Try to use dynamic selector that will help you to run same program in both the device.

Can you click on that text box with UiExplorer and paste the screenshot? I can try and help choose some better selectors - I would almost always avoid using index in your selector (right now you’re using idx=‘1’)

Looking at your selector, I don’t see anything terribly wrong. You could remove the idx, but it’s not going to fix it since the id is unique enough. Normally, I would suggest wildcarding the part with numbers in the id or looking for another attribute that’s more unique. If you use id, you could adjust it to '*EndAfter*' or if you are afraid of case-sensitivity *nd*fter*

but, like I said, your selector looks good enough in my opinion, so there is something else causing a problem.

Either the loading of the page was slower, and you need an adjustment to TimeoutMS… usually, the first element you interact with on the page should have a timeout of around 5000 or longer if loading is slow, and every element on the page right after should have a timeout of 0, since they should already be loaded at that point.

Or, the window size changed and it could not find the element for whatever reason. In this scenario, you could take a screenshot when the error occurs to see what the page looks like (TakeScreenshot activity and Save Image activity). If it’s a window size issue, try adding the Maximize Window activity in there, or if it’s a display size problem, then adjust the Robot settings in Orchestrator to run at the preferred HD resolution of 1920 by 1080, 32 bit depth.


@ClaytonM @Dave

Thank you - I resent the bot and it started working again - I will see if it happens again.

I have one last issue from running on a different machine that I posted on another topic - It would be helpful if you both could check it out! Thank you for all of the help.