2019.10 - Invoke Workflow error

Action creation can be placed in other workflow but post action activity “Wait for ***” should be in main, (as per my observation).

2 Likes

yes @megharajky i found the same .Thanks

This worked for me. Thank you so much

did but still getting same error

How you got it worked



Fixed my Persistence Error

ok thank you

I did it still the issue persists

1 Like

what if i want to invoke that orchestrator workflow with create form task and wait resume in a process work flow .Im getting issue in that scenario

image (1)

@Srishti_saxena

I think these two are still valid:

This means that you cannot use the Persistence activities from within an invoked workflow.
Could you show a screenshot of what you are trying to achieve if that’s not the case?

yes sure
1.This the orchestrator process where I have created a" create from task" and resume activity


2.This is simple process where I am invoking that orchestrator process
image (3)

But I am getting error
image (1)

1 Like

Hi @Srishti_saxena
Can you update the package

Thanks
Ashwin S

1 Like

I think you cannot use the Wait for Form Task and Resume activity in an invoked workflow. These persistence activities only work from the Main.xaml (or any workflow in you project that is marked as the main one).

3 Likes

I ran into the same issue. Well I think this is kind of nonsense that the Wait for Form Task and Resume needs to be in the Mail.xaml file.

If someone is using the ReFramework like we do, this is kind of impossible as the Process is in an extracted Process.xaml file.

So how to solve this now? Is there another way to resume? And if not, what is the sense of resuming something that may not be in an invoke.

1 Like

did you found a solution for this?

Yes, I extended the ReFramework. But the changes were huge!

Basically the idea was that I throw a custom exception in the process workflow. This exception contains the TaskObject as data parameter. And do not forget to serialize the object.

And then back in the main workflow I catch the custom exception and and deserialize it back. And now I have the TaskObject in the main workflow and can use it.

But I worked like a whole week on the implementation.

Sadly that this does not come directly from UiPath. Hope you got the idea. :slight_smile:

1 Like

hi all
here is the fix for that error
it work to change to the following setting in the project.json file?
“supportsPersistence”: true

Solved the problem in two steps :white_check_mark:
1: First of all go to the project settings.
2: Then enable the Supports Persistence.

image1

Great :expressionless:

Is there a reason for this? This just wasted 2 weeks of project time. So there’s no way to adjust the project settings? Or anything else to get it working?

EDIT: Tried looking at Project Setting, Persistence is set to on. Frankly this is a bug.

Hello @AlexanderERoss ,

I recorded these screen shots a while ago in a document. Therefore I must have run into these issues in the past. Can you see if these help? I’m shooting in the dark here, but one never knows.

image

image

Name of output object is set differently from the input:

image