Write Range: The range does not exist

I saw a few discussion on error that appears as “Write Range : The range does not exist”. However none solve my problem.
I am using Excel Application Scope - Write Range and it can be working fine and then suddenly it just doesn’t work. I redo the whole thing without making changes and it works again. Then after sometimes, it just doesnt work and has the same error i.e. “Write Range : The range does not exist”
May I know if this issue is a bug?
I read that the write range cannot be within the excel application scope. I tried using Workbook Write Range and it does write into the worksheet. However I have excel formulas so I want to write range with Excel Application.
May I know what could be the solution to write range using excel application scope? It was working fine in the afternoon. I did add a new ‘Assign’ into the Sequence and it does not work again. This new ‘Assign’ is able to write range when I use Workbook Write Range. So there should be nothing wrong with this new ‘Assign’.

Hi @GinaOng

Keep a message box and try to display the range. you might have mostly missed the alphabet part in the range. Please mark as solution if found useful.

example
A1:A10

Thanks. But I did not miss any part of the alphabet

Please provide what value you are getting for range.

Hi,
When I read range, I have used “” for read and write

Hi @GinaOng

Put “A1” in range for write range activity and see the output.
Please mark as solution if found useful :slight_smile:

Regards
Roshan

Hi Roshan,
Thanks. But it doesnt work too.

please forward your code

@unknownay Do I do a upload? Sorry. Have not done this before.

Yes zip your project and upload

if your data having formula nd that formula is wrong then u will get this error

2 Likes

I see. I will re-look into the formula.

Bit of a long shot, but if that doesn’t work it may be worth a try/investigate to make sure it isn’t a problem with Excel not exposing the cells to the UI application yet. Sort of like the robot equivalent of a human scrolling too fast down thousands of rows and excel taking a few seconds to catch up.

I realise this is unlikely, considering we all know the sheet does in deed contain those cells, but it may just be a quirk of how Excel interacts with its own underlying data, which is only highlighted when using RPA for excel in-application

Thank @ImPratham45. Indeed it is formula error.

Most Welcome!

Happy Automation!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.