With SFTP session Issue

Hi, getting a strange error while using FTP session activity. I have provided all the necessary values as below:

Error:
With Ftp Session: The argument of type ‘System.Boolean’ cannot be used. Make sure that it is declared on an activity.

Please assist. Thanks in advance!!

Hi,

This activity is unfriendly and returns this error even if, for example, the wrong port number is used. Can you check your network settings (server hostname and port number) and if reachable?

Regards,

I have provided the same values and tested in Filezila. It works!!
But the same values when passed through UiPath fails.

I have found the issue. Actually the error message is misleading.
I was including “sftp://” inside my hostname and by removing it and just including the hostname without “sftp://” did the job.

Also, getting this error back when you call the hostname from the config file. If hardcode the hostname, there is no error. Very strange!! Seems like a bug…
@loginerror @cristina.vidu

Hi,

Can you try to assign value of config to string variable just before WithFTPSession activity, then set break point on it and run as debug mode as the following?

We can see and check content of variable at Locals panel.

Regards,

Hey @amithvs

which version are you using?

FTP activities have couple of weird bugs and that needs to be addressed. If you are aware earlier versions of FTP were from official UiPath feed, they were quite stable. I suggest you to downgrade the version and try it out, there wikl be couple yog less properties to play around but it’ll be much more stable.

Yes confirmed the IP and port number and I am able to connect. The interesting thing is not sure what exactly the issue is, whether it is tied to some permission issue on the laptop, since I am using corporate managed laptop

Will try it today and update back.

2020.10.2 is the version I am using

This is the SFTP activity version I am using.
image
Latest Community Edition Studio (Stable)
I tried downgrading to the version just below the latest one, and the issue is still there, but the error message is different. I don’t remember exactly what the error is.
image

I did the debug as you suggested (this is with “sftp://” in the hostname)

Error:

image

Without “sftp://” there is no error now with assigning to a temp variable.

WIth_FTP_Session_Error.pdf (126.0 KB)

Assigned all the four as String variables. The issue still persists.

I hardcoded the values on the Assign activity for now, do I need to pull form the file instead?

Since this is the first time using the community for help, anyone know what would be the next step when there is no known resolution?

Have you tried like below:
Get every parameters except hostname from config file
Assign hostname into a string variable and pass it to the activity. Try with and without the sftp:// in the hostname…

Sorry about the delay in getting back to you. I tried just with hostname hardcoded but that didn’t work either. Just wondering is it some permission at OS level is what raising this error, may be?

Also only if the hostname hard code works it is not a solution that I can put in-place for every because that is not something that will work in our space.

does your hostname had the sftp:// part??