Errors thrown by With Ftp Session activity

I have configured the With Ftp Session activity with the following:

However after I run it I get the following error message:

RemoteException wrapping System.InvalidOperationException: The argument of type 'System.Boolean' cannot be used.  Make sure that it is declared on an activity. 
   at System.Activities.Argument.ThrowIfNotInTree()
   at System.Activities.Argument.Get[T](ActivityContext context)
   at UiPath.Shared.Activities.ContinuableAsyncNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value)
   at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value)
   at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

I have checked the credentials and the port and the ip that is supplied. They are correct. However I continue to hit the same error. Please assist.

1 Like

Hey @RobinsonFrancis

Were you able to connect to this server when tried manually please ?

May be you can try using WinSCP or Putty or any other tool


issue was more often reported by users. Maybe you can do a cross check with an alternate like ping, telnet… if FTP server can be reached with provided details. Optional also check for firewall blocks with the IT Team

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.