Receiving error 'System.Boolean' cannot be used while using With FTP Session

I am trying to use FTP.Activities but getting the getting the following error message. “With Ftp Session: The argument of type ‘System.Boolean’ cannot be used. Make sure that it is declared on an activity.”

Any help on this would be greatly appreciated. I searched a lot but not getting a hit. And tried setting a variable for ContinueOnError and used a variable but no luck.

3 Likes

Hi again
Did you solve the problem? Im getting the same issue…

Have a look here:

Nope, no luck yet. There was another thread got started for the same error. I am at a point now that I have to get this resolved. But the other thread I noticed it is active.

Hi. If the other thread is active can you please link it here?
Meanwhile waiting this would be fixed I replaced FTP Activities with WinSCP Activities which needs Invoke Code but is working fine as a temporary solution.

@JukS Please find the other thread’s link With SFTP session Issue - Help / Studio - UiPath Community Forum

I never tried WinSCP activity, but I will attempt that and update it here.

It might be due to firewall that connection is not getting established. I tested the activity and it is working without errors on a different VM.

@Srishti_1512 Good thought for sure. I am able to connect with WinSCP directly from the same laptop to the FTP manually and manually able to perform. What I am not sure is whether a connection from UiPath FTP activity being interpreted differently by the FTP server. I will have to take it up with system admins only to see if anything they can figure it out.

no answer still? I got this exact same error. but if I change to use user Id and password the workflow can function correctly.

This step resolved my issue

If you already have the private key, convert it to OpenSSH format using

PuttyGen->Load → select the private key → Menu → Conversion-> Export OpenSSH. (make sure to enter “.ppk” file extension manually). Save the Key file.
Now insert the new key path in Client Certificate path.

image

image

image

Thanks
Sai

Hello Guys,

I had the same error but I just used a previous version and it works for me.
Verison of activity I used is 1.0.7495.12930

Hope this helps!!

Thanks,
Yogendra

Hi, I was getting the same error. I though the error would come from the port, host, firewalls, etc. but it actually came from the password. I was just trying to convert the secure string from the credential to string, but not doing it properly. Therefore it couldn’t create the connection.

Used this and the error got solved:
String plainStr = new System.Net.NetworkCredential(string.Empty, secureStr).Password

Sharing in case someone is clumsy as me :slight_smile: