Website selectors not responding appropriately to UiPath activities

I’ve been tasked with automating a process for our Sales Tax team where I’m supposed to emulate logging onto a state website, going into what’s known as a “schedule,” and adding records from an Excel file to said schedule. There are a total of 9 fields the bot would interact with when adding a record, and for confidentiality reasons, I’ve censored and lettered them.

A: Dropdown menu
B: Date picker (can type in dd-MMM-yyyy format)
C: Dropdown menu
D: Dropdown menu (will not populate options until an option was chosen for C)
E: Dropdown menu
F: Dropdown menu (will not populate options until an option was chosen for E)
G: Text box
H: Read-only text box (updates when menu F has an option selected)
I: Read-only text box (updates when box G has a value and box H is not 0.00)

I’m not having any trouble interacting or sending input to any of the 9 fields listed above. My issue is that some of the dropdown menus (C, D, E, and F) don’t react properly to the bot’s Select Item activity. These are the steps the bot takes to enter these values.

  1. Select Item for C (data is from Excel file) + " County" string
  2. Send Tab Hotkey to C (bot is now focused on D)
  3. Send Enter Hotkey to D (hitting enter here after selecting an item for C “refreshes” D’s dropdown with options dependent on what was entered in C)
  4. Try catch: Try->Select Item for D (from Excel). Catch->ElementOperationException->Select Item for D (what’s known as the “unincorporated” option)

When the bot executes steps 1 through 4 on C and D, the little orange triangle in the upper left disappears, telling the website that there are values there (I assume). When the bot moves to repeat the steps on E and F, this is not the case. Specifically, menu E’s box will look like it has a value, but the yellow triangle does not disappear, which causes menu F to not refresh with options after the bot sends those tab and enter keys (steps 2 and 3). I thought maybe the order in which I entered these values matters as tabbing on that website actually takes you to E and F first, so I moved the E/F sequence above the C/D sequence but the same scenario happened.

I’ve tried just about all I can think of from sending extra keys to having the bot physically click on the dropdown in hopes of it expanding/updating but I’m getting nowhere. Is this a website specific thing I can’t get around or is there a UiPath way to fix this issue that I just haven’t tried yet?

Any feedback is appreciated, I can explain further if needed

1 Like

Hey @Kyle_Shahenian

So just to check my understanding, you want to choose a dependant drop-down only after it loads completely with options(after you choose parent drop-down) ?


Yes exactly. Dropdown D depends on C, and dropdown F depends on E. When I send a “Select Item” activity to C, D doesn’t reload right away. That’s when I implemented the fix of using 2 “Send Keys” activities to Tab from C, then Enter from D. That enter would refresh the list and allow a “Select Item” to be sent to D.

Everything I just described isn’t working for dropdown menus E and F and I’m not sure as to why. Even if I change the order in which the bot interacts with this form (E and F first, then C and D), that doesn’t work because it seems whichever set of dropdown menus the bot interacts with second will not fill appropriately.

1 Like

Hey @Kyle_Shahenian

You will need to do a small workaround here.

  1. Manually load the option in the dependant drop-down

  2. Use Element Exists with first option of the select item chosen as target with selector (remove aaname or innertext if any from selector)

  3. Add the above in the Retry Scope with some good retry numbers and wait time between retries

The above should resolve the issue.

Also please use the same approach which you are already using like passing Tab hotkey after selecting parent drop-down.



If by “first option” you mean the first item in the dependent dropdown list as a selector, unfortunately the website is not that robust and UiPath doesn’t recognize each individual option as a selector.

1 Like

Okay @Kyle_Shahenian

Not a problem. Do you have the selector for that select dependant drop-down?

If yes please post here


Not sure what happened exactly, but everything I just described on this forum post isn’t happening anymore. My bot is now adding records to the schedule as intended and not getting hung up on any of the dropdown menus. I didn’t make any changes to the code, and I wouldn’t think the website got updated overnight to patch what I was seeing, so I’m not exactly sure why this is now working.

During one of my tests, I did see an instance of the bot getting hung up the way I’ve described, but then on the next run it was entering units like its meant to.

1 Like

If one dropdown depends on the other, my guess is that at somepoint the site performance is affecting your automation.

There is a property on each activity called “WaitForReady” on the “Target” tab. If you have dependent elements, you can also try setting this property to “Complete”, this way the next activity (which would be the next selected item) will wait for the site to fully load before selecting the next dropdown.

Cool @Kyle_Shahenian

But if you face issues next time. Feel free to notify us here.


I don’t think it’s a matter of whether the dependent dropdown was fully loaded, I think my issue was rooted in the dropdown not refreshing properly even after successfully sending Tab-Enter hotkeys to that element. The bot doesn’t fail when trying to send those keys, it’s just that the elements aren’t responding despite being loaded to a point where you can actually send keys to it. If the dependent dropdown wasn’t even receiving the hotkey input from the bot then I would agree with you, but I don’t think that’s the case here.

1 Like

Hey @Kyle_Shahenian

Then please check the behaviour to pass an action appropriately.

May be click somewhere else after choosing parent drop-down may help.